php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57574 Undefined Symbol: OnUpdateBool
Submitted: 2007-03-15 11:33 UTC Modified: 2007-03-17 07:08 UTC
From: kosthorst at apobyte dot de Assigned:
Status: Not a bug Package: APC (PECL)
PHP Version: 5.1.6 OS: Debian Sarge
Private report: No CVE-ID: None
 [2007-03-15 11:33 UTC] kosthorst at apobyte dot de
Description:
------------
Configuration of APC:

'./configure' \
'--enable-apc' \
'--with-apxs' \
'--with-php-config=/usr/local/php5/bin/php-config' \

Restarting Apache2 (2.0.54) yields the following error:

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/php5/lib/php/extensions/no-debug-non-zts-20050922/apc.so' - /usr/local/php5/lib/php/extensions/no-debug-non-zts-20050922/apc.so: undefined symbol: OnUpdateBool in Unknown on line 0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-03-15 12:50 UTC] gopalv82 at yahoo dot com
http://cvs.php.net/viewvc.cgi/ZendEngine2/zend_ini.h?annotate=1.40

Tells me that OnUpdateBool has been in zend_ini.h since version 1.1
 [2007-03-15 12:55 UTC] rasmus@php.net
I can see this happening if your PHP header files you built APC against are out of synch with the version of PHP you are loading it into.
 [2007-03-16 05:14 UTC] kosthorst at apobyte dot de
OnUpdateBool is in '/usr/local/php5/include/php/Zend/zend_ini.h':
ZEND_API ZEND_INI_MH(OnUpdateBool);

According to 'php-config' and './configure', this file should have been used:

$ php-config --includes
-I/usr/local/php5/include/php -I/usr/local/php5/include/php/main -I/usr/local/php5/include/php/TSRM -I/usr/local/php5/include/php/Zend -I/usr/local/php5/include/php/ext

checking for PHP includes... -I/usr/local/php5/include/php -I/usr/local/php5/include/php/main -I/usr/local/php5/include/php/TSRM -I/usr/local/php5/include/ph
p/Zend -I/usr/local/php5/include/php/ext
checking for PHP extension directory... /usr/local/php5/lib/php/extensions/no-debug-non-zts-20050922
checking for PHP installed headers prefix... /usr/local/php5/include/php

However, I noticed PHP itself was configured with the option '--enable-versioning', which is marked as 'experts only'. Removing this and recompiling PHP and APC helped, APC works now.

Thank you for your help.
 [2007-03-17 07:08 UTC] gopalv82 at yahoo dot com
Issue with php build - not an APC bug.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Aug 20 05:01:27 2019 UTC