php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57541 build fails dynamic linking on Mac OS X
Submitted: 2007-02-21 20:35 UTC Modified: 2007-02-22 06:04 UTC
From: clay at killersoft dot com Assigned: mike (profile)
Status: Closed Package: pecl_http (PECL)
PHP Version: 5.2.1 OS: Mac OS X
Private report: No CVE-ID: None
 [2007-02-21 20:35 UTC] clay at killersoft dot com
Description:
------------
Attempting to set HttpResponse::setCache(true); or setGzip(true); results in a PHP crash on Mac OS X.

Reproduce code:
---------------
<?php
$xmlstr = '<?xml version="1.0"?>
<!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">
<cross-domain-policy>
   <allow-access-from domain="*.google.com"/>
</cross-domain-policy>';

HttpResponse::setCache(true);
HttpResponse::setGzip(true);
HttpResponse::setContentType('application/xml');
HttpResponse::setData($xmlstr);
HttpResponse::send();

Expected result:
----------------
The contents of $xmlstr in the body, and an eTag header in the response.


Actual result:
--------------
clay$ curl -i http://dev/crossdomain.php
dyld: lazy symbol binding failed: Symbol not found: _zend_update_static_property__Bool
  Referenced from: /usr/lib/php/extensions/no-debug-non-zts-20060613/http.so
  Expected in: flat namespace

dyld: Symbol not found: _zend_update_static_property__Bool
  Referenced from: /usr/lib/php/extensions/no-debug-non-zts-20060613/http.so
  Expected in: flat namespace

HTTP/1.1 500 Internal Server Error
Set-Cookie: TRACKID=1d57735d4fc20f39db94fb0d8c5bc22f; Path=/; Version=1
Content-Type: text/html
Content-Length: 369
Date: Thu, 22 Feb 2007 01:28:53 GMT
Server: lighttpd/1.4.13

<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
         "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
 <head>
  <title>500 - Internal Server Error</title>
 </head>
 <body>
  <h1>500 - Internal Server Error</h1>
 </body>
</html>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-22 03:54 UTC] mike@php.net
I assume this happens with any prioir version too.

Placing '#undef bool' in php_http_std_defs.h should fix this until I really stripped all those macros out.

Thanks.
 [2007-02-22 06:04 UTC] mike@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 25 04:03:37 2021 UTC