php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57528 session handler does not work (not registered)
Submitted: 2007-02-14 06:07 UTC Modified: 2007-02-14 08:35 UTC
From: gabriel at oxeva dot fr Assigned:
Status: Not a bug Package: memcache (PECL)
PHP Version: 4.4.4 OS: Linux 2.6
Private report: No CVE-ID: None
 [2007-02-14 06:07 UTC] gabriel at oxeva dot fr
Description:
------------
The summary explains all : in PHP4's configure, there is no option related to memcache session handler, nor memcache registered session handler in phpinfo. I think this is a bug as the feature is present in PHP5, so I assume the behavior must be the same in both PHP versions for the work-in-progress memcache 2.1.1.

Expected result:
----------------
Registered session handler list show the "memcache" session handler

Actual result:
--------------
No new registered session handler

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-14 07:21 UTC] tony2001@php.net
This option exists only in CVS version and you have to run ./buildconf --force if you build memcache using PHP source tree.
 [2007-02-14 07:22 UTC] tony2001@php.net
#/local/dev/php/4_4> ./configure --help | grep memca
  --enable-memcache       Enable memcache support
  --disable-memcache-session       Disable memcache session handler support
 [2007-02-14 07:27 UTC] pierre dot php at gmail dot com
test
 [2007-02-14 08:35 UTC] gabriel at oxeva dot fr
Sorry for the bogus, which is in fact another bug related to buildconf : when adding a pecl extension in the ext/ directory, then ./buildconf --force from a fresh decompressed php tarbal, the new configure script is built properly with the new extension options. BUT using removing configure script then ./buildconf --force a SECOND time doesn't update the configure script with new extensions (if they are added AFTER the first ./buildconf run). This a confused me because I replaced the memcache extension from 2.1.0 to CVS version between the 2 ./buildconf.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 03:03:14 2021 UTC