php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57505 uploadprogress_get_info not working if UPLOAD_IDENTIFIER is AFTER file element
Submitted: 2007-02-02 11:32 UTC Modified: 2007-07-17 05:10 UTC
From: massimiliano dot torromeo at gmail dot com Assigned:
Status: Not a bug Package: uploadprogress (PECL)
PHP Version: 5.2.0 OS: Linux
Private report: No CVE-ID: None
 [2007-02-02 11:32 UTC] massimiliano dot torromeo at gmail dot com
Description:
------------
I had an hard time finding out why my code didn't work and the example worked fine.
Turned out that if you place the UPLOAD_IDENTIFIER after the file element, it's impossible to retrieve uploadprogress_get_info data.

Reproduce code:
---------------
This works:
<input type="hidden" name="UPLOAD_IDENTIFIER" id="UPLOAD_IDENTIFIER"  value="1325a38f55c0b1b4" />
<input type="file" id="allegato" name="allegato" />

But this doesn't
<input type="file" id="allegato" name="allegato" />
<input type="hidden" name="UPLOAD_IDENTIFIER" id="UPLOAD_IDENTIFIER"  value="1325a38f55c0b1b4" />

Expected result:
----------------
array with uploadprogress data

Actual result:
--------------
NULL

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-07-17 05:10 UTC] chregu@php.net
Thank you for taking the time to write to us, but this is not
a bug.

Yes, it has to be before the first file element. Not 
solvable...
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 17 19:01:23 2020 UTC