php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57494 does not build with current PHP versions
Submitted: 2007-01-26 19:12 UTC Modified: 2015-05-24 04:22 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: judas dot iscariote at gmail dot com Assigned: cmb (profile)
Status: No Feedback Package: fann (PECL)
PHP Version: 5_2 CVS-2007-01-26 OS: Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2007-01-26 19:12 UTC] judas dot iscariote at gmail dot com
Description:
------------
this extension does not build with current gcc versions (gcc 4)



Reproduce code:
---------------
build the extension

Expected result:
----------------
compiled

Actual result:
--------------
/usr/src/packages/BUILD/fann-0.1.1/fann.c: In function 'zm_startup_fann':
/usr/src/packages/BUILD/fann-0.1.1/fann.c:393: error: 'zif_fannOO___set' undeclared (first use in this function)
/usr/src/packages/BUILD/fann-0.1.1/fann.c:393: error: (Each undeclared identifier is reported only once
/usr/src/packages/BUILD/fann-0.1.1/fann.c:393: error: for each function it appears in.)
/usr/src/packages/BUILD/fann-0.1.1/fann.c:403: error: 'zif_fannOO___get' undeclared (first use in this function)
/usr/src/packages/BUILD/fann-0.1.1/fann.c: In function 'zif_fann_create':
/usr/src/packages/BUILD/fann-0.1.1/fann.c:493: warning: assignment makes pointer from integer without a cast
make: *** [fann.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-26 19:48 UTC] judas dot iscariote at gmail dot com
Just figured this is caused cause this extension is incompatible with php5.2 it seems.
 [2007-10-25 12:03 UTC] lykantrop at yahoo dot co dot uk
It doesn't work neither with PHP >= 5.2 nor with FANN >= 2.0

Here's my ugly workaround:
Download and install FANN 1.2.0 the normal way.

Unpack the source for the module somewhere.
For PHP >= 5.2 and FANN module 0.1.1 in the file php_fann.h on line 28 comment out this "#define PHP_FANN_OO 1"

There's something terribly wrong with PECL in PHP >= 5.2, so do this instead:
phpize && ./configure && make && make install

(Plattform Slackware 12.0, PHP 5.2.3)

Please write somebody new PHP binding !!!
 [2015-05-12 14:20 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2015-05-12 14:20 UTC] cmb@php.net
Is that still an issue with recent fann releases?
 [2015-05-24 04:22 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 23 04:01:27 2019 UTC