php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57405 xdebug reports extra stack trace.
Submitted: 2006-11-29 03:37 UTC Modified: 2007-07-13 08:03 UTC
From: hiroaki dot kawai at gmail dot com Assigned:
Status: Not a bug Package: Xdebug (PECL)
PHP Version: 5.2.0 RC4 OS: Windows
Private report: No CVE-ID: None
 [2006-11-29 03:37 UTC] hiroaki dot kawai at gmail dot com
Description:
------------
I experienced that the xdebug produces extra stack 
trace in error_log that should not to be with
xdebug2.0RC1/PHP5.2.0/Apache2.2.3/WindowsXP.
(I got xdebug2.dll from http://www.xdebug.org/link.php?url=xdebug200rc1-520-win)

The Reproduce code is the following, the code does not 
display the stack trace on display(html), however,
stack trace is being logged in error_log.

IMHO the stack trace should not be logged because the exception is caught.

Reproduce code:
---------------
<?php
try{
	throw new Exception('caught!');
}catch(Exception $e){}
?>


Actual result:
--------------
[Wed Nov 29 17:33:20 2006] [error] [client 127.0.0.1] PHP Stack trace:
[Wed Nov 29 17:33:20 2006] [error] [client 127.0.0.1] PHP   1. {main}() D:\\apac
he\\front\\htdocs\\test.php:0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-07-13 08:03 UTC] derick@php.net
This is the wrong place for Xdebug bug reports, please go to http://bugs.xdebug.org. (Your issue might already be fixed, so please try the latest version (from CVS) first).
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jul 09 23:01:26 2020 UTC