php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57394 extension does not compile with php-5.2.0
Submitted: 2006-11-24 13:40 UTC Modified: 2017-04-01 21:08 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: zaa at zaa dot pp dot ru Assigned:
Status: Wont fix Package: Paradox (PECL)
PHP Version: 5_2 CVS-2006-11-24 OS: FreeBSD 6.2-PRERELEASE
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-11-24 13:40 UTC] zaa at zaa dot pp dot ru
Description:
------------
wave:...databases/pecl-paradox >uname -mrs
FreeBSD 6.2-PRERELEASE i386
wave:...databases/pecl-paradox >gcc -v
Using built-in specs.
Configured with: FreeBSD/i386 system compiler
Thread model: posix 
gcc version 3.4.6 [FreeBSD] 20060305
wave:...databases/pecl-paradox >php -v
PHP 5.2.0 with Suhosin-Patch 0.9.6.2 (cli) (built: Nov 23 2006 17:22:45)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
wave:...databases/pecl-paradox >make

===>  PHPizing for pecl-paradox-1.4.1
Configuring for: 
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
===>  Configuring for pecl-paradox-1.4.1 
configure: WARNING: you should use --build, --host, --target
checking for egrep... grep -E
checking for a sed that does not truncate output... /usr/bin/sed
checking for i386-portbld-freebsd6.2-gcc... cc 
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ANSI C... none needed
checking whether cc understands -c and -o together... yes
checking if compiler supports -R... yes
checking build system type... i386-portbld-freebsd6.2 
checking host system type... i386-portbld-freebsd6.2
checking target system type... i386-portbld-freebsd6.2
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/lib/php/20060613
checking for PHP installed headers prefix... /usr/local/include/php
checking for re2c... no 
configure: WARNING: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking for paradox support... yes, shared
checking for PX_create_blob_fp in -lpx... yes
checking for PX_insert_record in -lpx... no
checking for PX_update_record in -lpx... no
checking for PX_retrieve_record in -lpx... no
checking for PX_delete_record in -lpx... no
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... nm
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... cc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for i386-portbld-freebsd6.2-g++... c++
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking how to run the C++ preprocessor... c++ -E
checking the maximum length of command line arguments... (cached) 262144
checking command to parse nm output from cc object... ok
checking for objdir... .libs
checking for i386-portbld-freebsd6.2-ar... no
checking for ar... ar
checking for i386-portbld-freebsd6.2-ranlib... no
checking for ranlib... ranlib
checking for i386-portbld-freebsd6.2-strip... no
checking for strip... strip
checking if cc static flag  works... yes
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... yes
checking dynamic linker characteristics... freebsd6.2 ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by c++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the c++ linker (/usr/bin/ld) supports shared libraries... yes
checking for c++ option to produce PIC... -fPIC
checking if c++ PIC flag -fPIC works... yes
checking if c++ supports -c -o file.o... yes
checking whether the c++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... freebsd6.2 ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
configure: creating ./config.status
config.status: creating config.h
===>  Building for pecl-paradox-1.4.1
/bin/sh /usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/libtool --mode=compile cc  -I. -I/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1 -DPHP_ATOM_INC -I/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/include -I/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/main -I/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/local/include  -I/usr/local/include -DHAVE_CONFIG_H  -O2 -fno-strict-aliasing -pipe   -c /usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c -o paradox.lo
mkdir .libs
 cc -I. -I/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1 -DPHP_ATOM_INC -I/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/include -I/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/main -I/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/local/include -I/usr/local/include -DHAVE_CONFIG_H -O2 -fno-strict-aliasing -pipe -c /usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c  -fPIC -DPIC -o .libs/paradox.o
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:93:42: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:94:42: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:94: error: syntax error before "ZEND_ME_MAPPING"
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:95:46: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:96:38: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:97:48: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:98:46: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:99:48: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:100:48: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:113:46: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:114:48: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:115:44: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:116:54: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:117:54: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:118:46: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:119:46: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:120:64: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:121:54: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:122:54: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:123:60: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:124:50: macro "ZEND_ME_MAPPING" requires 4 arguments, but only 3 given
/usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1/paradox.c:126: error: syntax error before '}' token
*** Error code 1

Stop in /usr/obj/usr/ports/databases/pecl-paradox/work/paradox-1.4.1.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:08 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:08 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2007, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Oct 22 14:01:27 2019 UTC