php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57372 turning apc.rfc1867 on causes a Segmentation fault
Submitted: 2006-11-13 09:04 UTC Modified: 2006-11-14 10:07 UTC
From: slomo at sonarkollektiv dot de Assigned:
Status: Duplicate Package: APC (PECL)
PHP Version: 5.2.0 OS: Mac OS X 10.4.8
Private report: No CVE-ID: None
 [2006-11-13 09:04 UTC] slomo at sonarkollektiv dot de
Description:
------------
APC Version: 3.0.13-dev $Revision: 3.119 $

Apache: Apache/1.3.33 (shipped with Mac OS X)

PHP: PHP Version 5.2.0 (www.entropy.ch Release 3)

As soon as I say 'apc.rfc1867 = on' in my php.ini, Apache 
starts throwing errors like "child pid [number] exit signal 
Segmentation fault (11)" in the error log. Everything else 
looks fine (APC got installed, it shows up @ phpinfo() )

I assume debugging is impossible with this lack of 
information?

I'm desperate at the moment. All I'm looking for is the 
gorgeous "File Upload Hook" everybody is talking about - but 
the available information is so small, it's ridiculous. 
Everyone is citing each other, always pointing to the funny 
2 document we have in the net so far.

http://blog.bitflux.ch/archive/tag/uploadprogress/ and
http://progphp.com/progress.php

Please advise me with any tipps how to move on. If you need 
a project homepage I could make you one :)

Maybe this helps:

(gdb) run -X
Starting program: /usr/sbin/httpd -X
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries ... done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries . done
Reading symbols for shared libraries ........ done
Processing config directory: /private/etc/httpd/users/*.conf
 Processing config file: /private/etc/httpd/users/kati.conf
 Processing config file: /private/etc/httpd/users/slomo.conf
Reading symbols for shared 
libraries ..................................................
....................... done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries . done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries . done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries . done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries . done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries . done
Reading symbols for shared libraries ... done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done

Program received signal EXC_BAD_ACCESS, Could not access 
memory.
Reason: KERN_INVALID_ADDRESS at address: 0x7c7d1b78
0x024c378c in zend_hash_index_find ()


PHP
./configure
	--prefix=/usr/local/php5
	--with-apxs
	--with-config-file-scan-dir=/usr/local/php5/php.d
	--with-iconv
	--with-openssl=/usr
	--with-zlib=/usr
	--with-gd
	--with-zlib-dir=/usr
	--with-ldap
	--with-xmlrpc
	--with-iconv-dir=/usr
	--with-snmp=/usr
	--enable-exif
	--enable-wddx
	--enable-soap
	--enable-sqlite-utf8
	--enable-ftp
	--enable-sockets
	--enable-dbx
	--enable-dbase
	--enable-mbstring
	--enable-calendar
	--enable-bcmath
	--with-bz2=/usr
	--enable-memory-limit
	--with-curl=shared,/usr/local/php5
	--with-mysql=shared,/usr/local/php5
	--with-mysqli=shared,/usr/local/php5/bin/mysql_config
	--with-pdo-mysql=shared,/usr/local/php5
	--with-libxml-dir=shared,/usr/local/php5
	--with-xsl=shared,/usr/local/php5
	--with-pdflib=shared,/usr/local/php5
	--with-oci8=shared,instantclient,/usr/local/php5/oracle
	--with-pdo-oci=shared,instantclient,/usr/local/php5/
oracle,10.1.0.3
	--with-imap=../imap-2004g
	--with-kerberos=/usr
	--with-imap-ssl=/usr
	--with-jpeg-dir=/usr/local/php5
	--with-png-dir=/usr/local/php5
	--enable-gd-native-ttf
	--with-freetype-dir=/usr/local/php5
	--with-iodbc=shared,/usr
	--with-pgsql=shared,/usr/local/php5
	--with-pdo-pgsql=shared,/usr/local/php5
	--with-t1lib=/usr/local/php5
	--with-gettext=shared,/usr/local/php5
	--with-ming=shared,/usr/local/php5
	--with-mcrypt=shared,/usr/local/php5
	--with-mhash=shared,/usr/local/php5
	--with-mssql=shared,/usr/local/php5
	--with-fbsql=shared,/Users/liyanage/svn/entropy/
universalbuild/src/FBDeveloperLibraries/Library/FrontBase
	--with-json=shared
	--enable-memcache
	--enable-openbase_module

APC
./configure
	--enable-apc-mmap
	--with-apxs
	--with-php-config=/usr/local/php5/bin/php-config

regards,
  slomo


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-13 10:53 UTC] slomo at sonarkollektiv dot de
just corrected the PHP Version number
 [2006-11-14 05:51 UTC] olivier at reagi dot com
This seems to be the same bug as
#9312
 [2006-11-14 10:07 UTC] gopalv82 at yahoo dot com
Marking as duplicate of #9312 - it is being worked upon
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Aug 04 16:01:23 2021 UTC