php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57360 libcurl version error in configure
Submitted: 2006-11-08 16:49 UTC Modified: 2006-11-09 08:43 UTC
From: keith at iveys dot org Assigned: mike (profile)
Status: Closed Package: pecl_http (PECL)
PHP Version: 5.1.6 OS: FC3
Private report: No CVE-ID: None
 [2006-11-08 16:49 UTC] keith at iveys dot org
Description:
------------
I get this error on configure:

checking for curl version >= 7.12.3... 7.12.3
configure: error: libcurl version greater or equal to 7.12.3 required

The problem is that the check for libcurl version should be like the one for libz

-        if test `echo $CURL_VERSION | $AWK '{print $1*10000 + $2*100 + $3}'` -lt 71203; then
+        if test `echo $CURL_VERSION | $SED -e 's/[^0-9]/ /g' | $AWK '{print $1*10000 + $2*100 + $3}'` -lt 71203; then

Without the sed, it's not splitting the version number, so you just get '7.12.3' * 10000 = 71200, so it thinks the version is too low.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-09 08:43 UTC] mike@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 25 11:03:37 2021 UTC