php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57349 memcache session handler doesn't work with phpMyAdmin
Submitted: 2006-11-06 20:33 UTC Modified: 2006-11-07 03:40 UTC
From: aleast at capri dot it Assigned:
Status: Not a bug Package: memcache (PECL)
PHP Version: 5.1.4 OS: Linux Debian 3.1
Private report: No CVE-ID: None
 [2006-11-06 20:33 UTC] aleast at capri dot it
Description:
------------
I have configured memcached with session support and everything works fine except phpMyAdmin.

Here is my php.ini relevant configuration:

session.save_handler = "memcache"
session.save_path = "tcp://192.168.0.31:11211"
extension=memcache.so

And following phpMyAdmin errors:

Warning: session_write_close() [function.session-write-close]: open(tcp://192.168.0.31:11211/sess_M04inOfzTTqqNARdqzxc,3zIp,a, O_RDWR) failed: No such file or directory (2) in /www/phpMyAdmin/index.php on line 44

Warning: session_write_close() [function.session-write-close]: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (tcp://192.168.0.31:11211) in /www/phpMyAdmin/index.php on line 44


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-07 02:08 UTC] mikael at synd dot info
Looks like the "files" save handler is used even though you have specified session.save_handler = "memcache", this is most likely caused by

 *  The server config or a /www/phpMyAdmin/.htaccess file containing "php_value save_handler files" 
 * phpMyAdmin itself doing an ini_set('save_handler','files')

If the memcache save handler was indeed used sess_M04inOfzTTqqNARdqzxc would not have been appended to save_path and you would have gotten an E_NOTICE like "marked server '192.168.0.31:11211' as failed", the call to "open(..,3zIp,a, O_RDWR)" is also an indication of "files" being used as memcache doesn't use this function but "files" do.
 [2006-11-07 03:40 UTC] aleast at capri dot it
Thank you for the reply. You are right, it's a phpMyAdmin fault. The broken line is in libraries/session.inc.php at line 79 (phpMyAdmin 2.9.0.3):

// [2006-01-25] Nicola Asuni - www.tecnick.com: maybe the PHP directive
// session.save_handler is set to another value like "user"
ini_set('session.save_handler', 'files');

Commenting out this line, everything works fine.
 [2008-09-15 03:19 UTC] wan_979 at yahoo dot com
VAUP
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 10:03:34 2021 UTC