php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57237 Many memory leaks every second
Submitted: 2006-09-14 06:34 UTC Modified: 2007-02-17 23:46 UTC
From: marrtins at hackers dot lv Assigned:
Status: Duplicate Package: APC (PECL)
PHP Version: 5.1.5 OS: Linux 2.6.14.4 i686
Private report: No CVE-ID: None
 [2006-09-14 06:34 UTC] marrtins at hackers dot lv
Description:
------------
I run a bit bussy webserver (2x1gHz CPU, 1Gg RAM) of average 120 cache req/sec on Apache 1.3.36

I compiled PHP with debug info and every sec get a lot of mem leak reports from APC in my error.log

However, site is running very stable - no segfaults and died Apache processes.

I used eAccelerator before and got the same reports of mem leaks, however I also got a lot of apache crashes.

Hope this information will helps. 

Reproduce code:
---------------
[Thu Sep 14 13:31:03 2006]  Script:  '/home/marrtins/counter/public/counter.php'
/usr/src/APC-3.0.12p2/apc_zend.c(35) :  Freeing 0x0899FD84 (4 bytes), script=/home/marrtins/counter/public/counter.php
Last leak repeated 283 times
[Thu Sep 14 13:31:03 2006]  Script:  '/home/marrtins/counter/public/counter.php'
/usr/src/APC-3.0.12p2/apc_compile.c(1973) :  Freeing 0x089A0A04 (140 bytes), script=/home/marrtins/counter/public/counter.php
Last leak repeated 134 times
[Thu Sep 14 13:31:03 2006]  Script:  '/home/marrtins/counter/public/counter.php'
/usr/src/APC-3.0.12p2/apc_compile.c(1991) :  Freeing 0x089F021C (380 bytes), script=/home/marrtins/counter/public/counter.php
=== Total 420 memory leaks detected ===
[Thu Sep 14 13:31:03 2006]  Script:  '/home/marrtins/counter/public/counter.php'
/usr/src/APC-3.0.12p2/apc_zend.c(35) :  Freeing 0x08A621F4 (4 bytes), script=/home/marrtins/counter/public/counter.php
Last leak repeated 284 times
[Thu Sep 14 13:31:03 2006]  Script:  '/home/marrtins/counter/public/counter.php'
/usr/src/APC-3.0.12p2/apc_compile.c(1973) :  Freeing 0x08A2EAAC (140 bytes), script=/home/marrtins/counter/public/counter.php
Last leak repeated 134 times
[Thu Sep 14 13:31:03 2006]  Script:  '/home/marrtins/counter/public/counter.php'
/usr/src/APC-3.0.12p2/apc_compile.c(1991) :  Freeing 0x08A270EC (380 bytes), script=/home/marrtins/counter/public/counter.php
=== Total 421 memory leaks detected ===
[Thu Sep 14 13:31:03 2006]  Script:  '/home/marrtins/counter/public/counter.php'
/usr/src/APC-3.0.12p2/apc_zend.c(35) :  Freeing 0x08A24164 (4 bytes), script=/home/marrtins/counter/public/counter.php
Last leak repeated 284 times
[Thu Sep 14 13:31:03 2006]  Script:  '/home/marrtins/counter/public/counter.php'
/usr/src/APC-3.0.12p2/apc_compile.c(1973) :  Freeing 0x089F8274 (140 bytes), script=/home/marrtins/counter/public/counter.php
Last leak repeated 134 times
[Thu Sep 14 13:31:03 2006]  Script:  '/home/marrtins/counter/public/counter.php'
/usr/src/APC-3.0.12p2/apc_compile.c(1991) :  Freeing 0x08A255C4 (380 bytes), script=/home/marrtins/counter/public/counter.php
=== Total 421 memory leaks detected ===
[Thu Sep 14 13:31:04 2006]  Script:  '/home/marrtins/counter/public/cc.php'
/usr/src/APC-3.0.12p2/apc_zend.c(35) :  Freeing 0x08A32804 (4 bytes), script=/home/marrtins/counter/public/cc.php
Last leak repeated 120 times
[Thu Sep 14 13:31:04 2006]  Script:  '/home/marrtins/counter/public/cc.php'
/usr/src/APC-3.0.12p2/apc_compile.c(1973) :  Freeing 0x089F9C5C (140 bytes), script=/home/marrtins/counter/public/cc.php
Last leak repeated 115 times
=== Total 237 memory leaks detected ===
[Thu Sep 14 13:31:04 2006]  Script:  '/home/marrtins/counter/public/cc.php'
/usr/src/APC-3.0.12p2/apc_zend.c(35) :  Freeing 0x08A256C4 (4 bytes), script=/home/marrtins/counter/public/cc.php
Last leak repeated 120 times
[Thu Sep 14 13:31:04 2006]  Script:  '/home/marrtins/counter/public/cc.php'
/usr/src/APC-3.0.12p2/apc_compile.c(1973) :  Freeing 0x089F6CF4 (140 bytes), script=/home/marrtins/counter/public/cc.php
Last leak repeated 115 times
=== Total 237 memory leaks detected ===
[Thu Sep 14 13:31:04 2006]  Script:  '/home/marrtins/counter/public/counter.php'
/usr/src/APC-3.0.12p2/apc_zend.c(35) :  Freeing 0x089ED684 (4 bytes), script=/home/marrtins/counter/public/counter.php
Last leak repeated 283 times
[Thu Sep 14 13:31:04 2006]  Script:  '/home/marrtins/counter/public/counter.php'
/usr/src/APC-3.0.12p2/apc_compile.c(1973) :  Freeing 0x089ED404 (140 bytes), script=/home/marrtins/counter/public/counter.php
Last leak repeated 134 times
[Thu Sep 14 13:31:04 2006]  Script:  '/home/marrtins/counter/public/counter.php'
/usr/src/APC-3.0.12p2/apc_compile.c(1991) :  Freeing 0x08A05094 (380 bytes), script=/home/marrtins/counter/public/counter.php
=== Total 420 memory leaks detected ===



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-17 23:46 UTC] shire@php.net
This is a duplicate of #7119, it's a known issue and doesn't result in "actual" memory being leaked.  Also, running in debug mode is going to slow your server down considerably, I wouldn't recomend it unless you actually need to debug.  Thanks.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Aug 02 23:01:23 2021 UTC