php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57228 udm_alloc_agent() ignores 2nd argument
Submitted: 2006-09-12 16:05 UTC Modified: 2017-04-01 20:53 UTC
From: pecl_dot_php_dot_net at edelhost dot de Assigned:
Status: Wont fix Package: mnogosearch (PECL)
PHP Version: 5.1.6 OS: Linux 2.6.17.8.k7
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-09-12 16:05 UTC] pecl_dot_php_dot_net at edelhost dot de
Description:
------------
Version information:
PECL::mnogosearch: 1.0.0
mnogosearch: 3.2.37
postgresql: 8.1.4

I've tried to set the dbmode to 'multi' like described in http://de.php.net/manual/en/function.udm-alloc-agent.php, but it won't work. All I'll get are empty results.

Reproduce code:
---------------
<?php
error_reporting(4095);
ini_set('display_errors', 'On');
define('UDM_DBADDR', 'pgsql://user:password@/database/');
define('UDM_DBMODE', 'multi');
$agent0 = udm_alloc_agent(UDM_DBADDR, UDM_DBMODE)
    or die("Wrong argumnets for agent0");
$agent1 = udm_alloc_agent(UDM_DBADDR.'?dbmode=multi',
    'Insert whatever you like, or not, except NULL.')
    or die("Wrong argumnets for agent1");
udm_set_agent_param($agent0, UDM_PARAM_WORD_MATCH, UDM_MATCH_BEGIN);
udm_set_agent_param($agent1, UDM_PARAM_WORD_MATCH, UDM_MATCH_BEGIN);
$res0 = udm_find($agent0, 'bugreport');
$res1 = udm_find($agent1, 'bugreport');
printf("Result0 contains %d matches\n", udm_get_res_param($res0,
    UDM_PARAM_NUM_ROWS));
printf("Result1 contains %d matches\n", udm_get_res_param($res1,
    UDM_PARAM_NUM_ROWS));
?>

Expected result:
----------------
Result0 contains 5 matches
(max:) Result1 contains 0 matches
(min:) notice or warning

Actual result:
--------------
Result0 contains 0 matches
Result1 contains 5 matches

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 20:53 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 20:53 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2006, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 27 23:03:36 2021 UTC