php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57222 Compilation fails with mnogosearch and apxs2
Submitted: 2006-09-08 11:03 UTC Modified: 2006-09-08 11:41 UTC
From: scholz at digi-info dot de Assigned: pajoye (profile)
Status: Not a bug Package: mnogosearch (PECL)
PHP Version: 4.4.4 OS: Suse 10.0 x86_64
Private report: No CVE-ID: None
 [2006-09-08 11:03 UTC] scholz at digi-info dot de
Description:
------------
Description:
------------
Hi i want to activate the mnogosearch extension in php4.

" ./configure --with-mnogosearch" 

works fine but 

" ./configure 
--with-mnogosearch --with-apxs2=/usr/sbin/apxs2-prefork"

will produce

/usr/lib64/gcc/x86_64-suse-linux/4.0.2/../../../../x86_64-suse-linux/bin
/ld: /usr/local/mnogosearch/lib/libmnogosearch.a(indexer.o): relocation
R_X86_64_32 against `a local symbol' can not be used when making a
shared object; recompile with -fPIC
/usr/local/mnogosearch/lib/libmnogosearch.a(indexer.o): could not read
symbols: Bad value
collect2: ld returned 1 exit status
make: *** [libphp4.la] Error 1

The mnogosearch version is mnogosearch-3.2.39.

Greetings Stefan


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-09-08 11:41 UTC] pierre dot php at gmail dot com
It is not a problem in the mnogosearch extension but either in your apache or mnogosearch builds. Check that they are all compiled in 64bit and/or using -fPIC.

If you use suse binaries, try to report a bug by suse.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 22 22:01:24 2020 UTC