php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57167 specifing policy on kadm5_create_principal()
Submitted: 2006-08-01 06:06 UTC Modified: 2017-04-01 20:44 UTC
From: klem at linux dot ee Assigned:
Status: Wont fix Package: kadm5 (PECL)
PHP Version: 4.4.1 OS: Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-08-01 06:06 UTC] klem at linux dot ee
Description:
------------
Basically same code as php.net manual example gives error:
Warning: No policy specified for blaah...; assigning "default" .


Reproduce code:
---------------
..

$attributes=KRB5_KDB_REQUIRES_PRE_AUTH|KRB5_KDB_DISALLOW_PROXIABLE;
$options = array(KADM5_PRINC_EXPIRE_TIME => 0,
                            KADM5_PW_EXPIRATION => 0,
                            KADM5_POLICY => "default",
                            KADM5_ATTRIBUTES => $attributes);

return kadm5_modify_principal($this->krb_con,"principal/default@EXAMPLE.COM",$options);


Expected result:
----------------
no errors

Actual result:
--------------
warning, that no policy was specified and a default policy was assigned

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 20:44 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 20:44 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2003, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Oct 19 16:01:24 2020 UTC