php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57116 shm_segments doesn't work
Submitted: 2006-06-29 08:43 UTC Modified: 2007-09-18 20:07 UTC
From: franzhaenel at hotmail dot com Assigned:
Status: Duplicate Package: APC (PECL)
PHP Version: 5.1.2 OS: Ubuntu 6.06 /FC3,4
Private report: No CVE-ID: None
 [2006-06-29 08:43 UTC] franzhaenel at hotmail dot com
Description:
------------
In the later CVS-versions apc.shm_segments doesn't work anymore. Any number above 1 is reduced to 1 segment.

PHP 5.14
Apache 1.3.36
Latest APC CVS

PHP:
./configure --with-apxs=/usr/local/apache/bin/apxs --prefix=/usr/local --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-mbstring --enable-mbstr-enc-trans --enable-mbregex --with-mcrypt --enable-magic-quotes --with-mysqli --with-mysql=/usr --with-openssl --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-zlib

APC:
./configure --enable-apc --with-apxs=/usr/local/apache/bin/apxs --with-php-config=/usr/local/bin/php-config

extension=apc.so
apc.enabled = 1
apc.shm_size = 30
apc.shm_segments = 10


Reproduce code:
---------------
Just run apc.php

Expected result:
----------------
From apc.php

General Cache Information
...
Shared Memory	10 Segment(s) with 30.0 MBytes

Runtime Settings
...
apc.shm_segments	10

Actual result:
--------------
From apc.php

General Cache Information
...
Shared Memory	1 Segment(s) with 30.0 MBytes

Runtime Settings
...
apc.shm_segments	10

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-06-29 08:46 UTC] rasmus@php.net
Why do you want multiple segments?
 [2006-06-29 09:34 UTC] franzhaenel at hotmail dot com
We had problems before with too large segments so we have always used multiple 30MB segments. I checked, however, and it works fine now with a larger segment.
 [2007-02-17 23:55 UTC] shire@php.net
duplicate of bug #8069.
 [2007-08-10 16:49 UTC] sean at awesomeplay dot com
Why is this bug marked as a duplicate of itself?

Also, I'm experiencing this bug.  The 32MB max segment size fills up in about 3 seconds on our server.
 [2007-09-18 20:07 UTC] shire@php.net
Sorry I must have got my bug #'s mixed up.  

Consuming all of your APC memory isn't necessarily a bug.  The shared memory size is going to be proportional to the amount of files and user variables you insert into the cache.  You should probably increase your memory size.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Dec 05 06:01:23 2020 UTC