php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57045 PDO_DBLIB install problem
Submitted: 2006-05-29 03:45 UTC Modified: 2011-12-01 05:51 UTC
From: foxiii at korea dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 5_1 CVS-2006-05-29 OS: CentOS 4.3
Private report: No CVE-ID: None
 [2006-05-29 03:45 UTC] foxiii at korea dot com
Description:
------------
PDO_DBLIB install problem.

I required PDO for MSSQL.
So, I install PHP 5.1.4 (--enable-pdo=shared)
but, I can't show complete message on install PDO_DBLIB, showed message 
"pear/PDO_DBLIB requires PHP extension "pdo" (version >= 1.0)"
======================================
./pecl upgrade PDO          = is OK
./pecl upgrade PDO_SQLITE   = is OK
./pecl upgrade PDO_DBLIB    = failed
======================================

======================================
[root@devserv bin]# ./pecl list-all
ALL PACKAGES:
=============
PACKAGE            LATEST   LOCAL
pecl/PDO                    1.0.3 PHP Data Objects Interface
pecl/PDO_SQLITE             1.0.1 SQLite v3 Interface driver for PDO
======================================
======================================
[root@devserv bin]# rpm -qa | grep freetds
freetds-0.63-1.2.el4.rf
======================================

Result, I installed PDO1.0.3, but, PDO_DBLIB want PDO>=1.0.
I installed PDO_SQLITE nothing any error, just has problem on PDO_DBLIB...

Plz, solve it.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-29 03:49 UTC] foxiii at korea dot com
Oh.. not match package field.
 [2006-05-29 04:12 UTC] foxiii at korea dot com
.
 [2009-02-03 12:24 UTC] camden dot michael at gmail dot com
I had this same issue, and since it was reported about 2 years ago with no movement, it doesn't seem like the developers are going to work on this anytime soon.

I was able to "fix" this issue, by downloading the pdo_dblib pecl extension, removing the pdo 1.0 dependency, and installing from my local copy.

Here are the steps I took,

pecl download pdo_dblib

This will download a tar ball of the extension. Extract the tar ball.

tar -xzvf PDO_DBLIB-*.tgz

That will uncompress the package in to a standalone file, package.xml and a folder containing the extension, in my case it was, PDO_DBLIB-X.X. Where X was the version number. Open package.xml using your favourite command line editor. Find and remove the line,

<dep type="ext" rel="ge" version="1.0">pdo</dep>

Save the package.xml file, and move it in to the PDO_DBLIB directory.

mv package.xml ./PDO_DBLIB-X.X

Navigate to the PDO_DBLIB directory, then install the package from the directory. You may need root access for this step.

cd PDO_DBLIB-X.X PHP_PDO_SHARED=1 pecl install package.xml
 [2010-06-16 16:30 UTC] liam at morland dot ca
Another solution: pecl install -n pdo_dblib
The -n makes it skip dependencies.
 [2011-12-01 05:51 UTC] ssufficool@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

The built in PDO extension in 5.4 should be more feature complete and have less bugs. The PECL extension is over 6 years old.
 [2011-12-01 05:51 UTC] ssufficool@php.net
-Status: Open +Status: Bogus -Package: PDO_DBLIB +Package: *General Issues
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC