php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57032 vpopmail module installation fail
Submitted: 2006-05-22 20:45 UTC Modified: 2015-01-08 23:01 UTC
From: leventildeniz at istanbul dot edu dot tr Assigned:
Status: Duplicate Package: vpopmail (PECL)
PHP Version: 5.1.1 OS: fedora core 4 - core 5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: leventildeniz at istanbul dot edu dot tr
New email:
PHP Version: OS:

 

 [2006-05-22 20:45 UTC] leventildeniz at istanbul dot edu dot tr
Description:
------------
installing vpopmail module on fedora core 4 or core 5 .it' s fail of the instatallation 
#pecl install vpopmail-0.2.tgz

Starting to download vpopmail-0.2.tgz (8,970 bytes)
.....done: 8,970 bytes
3 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20050922
Zend Extension Api No:   220051025
Vpopmail install directory? [autodetect] :
....
......
.......
......
/tmp/tmppfebbI/vpopmail-0.2/php_vpopmail.c:288: warning: passing argument 3 of '                                                                             add_domain_assign' makes pointer from integer without a cast
/tmp/tmppfebbI/vpopmail-0.2/php_vpopmail.c:288: error: too few arguments to func                                                                             tion 'add_domain_assign'
make: *** [php_vpopmail.lo] Error 1
ERROR: `make' failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-11 18:02 UTC] bunzel at gmail dot com
Can confirm this bug on Gentoo and likely other distributions are affected too. 

The problem is in the configure script which tries to determine the version of vpopmail by calling

version=`grep VERSION $VPOPMAIL_INC_DIR/vpopmail_config.h`

and doing some processing afterwards. In my local version this matches VERSION and PACKAGE_VERSION, leading to "5\n5" as output which makes the further processing and thereby the version detection fail. 

As a quick and dirty fix one could change the line above in "configure" to 

version=`grep VERSION $VPOPMAIL_INC_DIR/vpopmail_config.h | head -n 1`

which truncates the output to only one line.
 [2007-06-13 04:01 UTC] rob at tdd dot org dot uk
Here is a patch as a nasty work around, but it got me beyond that problem.

It seem's like HAVE_VPOPMAIL_API and HAVE_VPOPMAIL_AUTH are not being defined and so it tries to compile against an older version of vpopmail.

--- vpopmail-0.2.old/php_vpopmail.c     2003-01-17 17:13:03.000000000 +0000
+++ vpopmail-0.2/php_vpopmail.c 2007-06-13 07:47:20.000000000 +0000
@@ -50,6 +50,8 @@
 #undef PACKAGE
 #include "vpopmail_config.h"
 #include "vpopmail.h"
+#define HAVE_VPOPMAIL_API 2
+#define HAVE_VPOPMAIL_AUTH 1
 #if HAVE_VPOPMAIL_VAUTH
 #include "vauth.h"
 #endif
 [2015-01-08 23:01 UTC] ajf@php.net
-Status: Open +Status: Duplicate
 [2015-01-08 23:01 UTC] ajf@php.net
Duplicate of this: https://bugs.php.net/bug.php?id=56099
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Nov 27 21:01:35 2020 UTC