php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56099 Make error
Submitted: 2004-06-16 10:27 UTC Modified: 2015-03-23 19:57 UTC
From: misterics at hotmail dot com Assigned:
Status: Not a bug Package: vpopmail (PECL)
PHP Version: 4.3.3 OS: fedore core1 / php 4.3.7
Private report: No CVE-ID: None
 [2004-06-16 10:27 UTC] misterics at hotmail dot com
Description:
------------
I've added the module to thew ext dir, i've execute the ./buildconf... 
all ok!
then...
the ./configure --with-vpopmail=home/vpopmail...
all ok!
then...
make...
this is the error:
/usr/src/php-4.3.7/ext/vpopmail/php_vpopmail.c: In function `zif_vpopmail_add_alias_domain':
/usr/src/php-4.3.7/ext/vpopmail/php_vpopmail.c:288: warning: passing arg 3 of `add_domain_assign' makes pointer from integer without a cast
/usr/src/php-4.3.7/ext/vpopmail/php_vpopmail.c:288: error: too few arguments to function `add_domain_assign.

The make failed.could you help me?

thanks
marco

Reproduce code:
---------------
/usr/src/php-4.3.7/ext/vpopmail/php_vpopmail.c: In function `zif_vpopmail_add_alias_domain':
/usr/src/php-4.3.7/ext/vpopmail/php_vpopmail.c:288: warning: passing arg 3 of `add_domain_assign' makes pointer from integer without a cast
/usr/src/php-4.3.7/ext/vpopmail/php_vpopmail.c:288: error: too few arguments to function `add_domain_assign


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-11-05 06:01 UTC] amiroot at yahoo dot com
I encounter this error too. I'm using php4.3.10-dev and Fedora 2
 [2004-11-24 09:35 UTC] sven at root dot lu
I have the same problem :-(

someone found a solution ?
 [2015-03-23 19:57 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2015-03-23 19:57 UTC] cmb@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 13:01:24 2020 UTC