php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57031 Warning: RarEntry::extract() [function.extract]: ERAR_EOPEN in ....
Submitted: 2006-05-22 11:18 UTC Modified: 2009-11-28 22:55 UTC
From: boobsd at gmail dot com Assigned:
Status: Not a bug Package: rar (PECL)
PHP Version: 5.0.5 OS: OpenBSD-3.9
Private report: No CVE-ID: None
 [2006-05-22 11:18 UTC] boobsd at gmail dot com
Description:
------------
Not all entries of archive are extracting. But only no more than 114 files. Sometimes less then 114 files.

See my phpinfo() in http://yolka.homeunix.net/phpinfo.php

Reproduce code:
---------------
<?
$rar_file = rar_open('01.01.06.rar') or die("Can't open Rar archive");
$list = rar_list($rar_file);
foreach ($list as $file) {
  echo($file->getName()."<br>");
  $entry = $file;
  $entry->extract('unpack');
}
rar_close($rar_file);
?>


Expected result:
----------------
Extracting all entries of archive.


Actual result:
--------------
It is being unpacked no more than 114 files regardless size:

01.01.06/IMGP2391.JPG
01.01.06/IMGP2392.JPG
01.01.06/IMGP2393.JPG
---- CUT HERE ----
01.01.06/P1090198.JPG
01.01.06/P1090199.JPG

Warning: RarEntry::extract() [function.extract]: ERAR_EOPEN in /mnt/data/www/htdocs/test/rar.php on line 7
01.01.06/P1090200.JPG

Warning: RarEntry::extract() [function.extract]: ERAR_EOPEN in /mnt/data/www/htdocs/test/rar.php on line 7
01.01.06/P1090201.JPG

etc..

gdb output:

(gdb) run -X
Starting program: /usr/sbin/httpd -X
warning: libm.so.2.1: minor version >= 2 expected, using it anyway
^C
Program received signal SIGINT, Interrupt.
0x07a585c1 in accept () from /usr/lib/libc.so.39.0
(gdb) bt
#0  0x07a585c1 in accept () from /usr/lib/libc.so.39.0
#1  0x1c03f063 in ap_child_terminate ()
#2  0x1c03f62e in ap_child_terminate ()
#3  0x1c03f69c in ap_child_terminate ()
#4  0x1c040131 in ap_child_terminate ()
#5  0x1c0406d7 in main ()


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-13 18:29 UTC] tony2001 at phpclub dot net
Any chance to get that archive file to testing?
 [2007-10-21 05:48 UTC] flyingzf at 126 dot com
warning: libm.so.2.1: minor version >= 3 expected, using it anyway
 [2009-11-28 22:55 UTC] glopes at nebm dot ist dot utl dot pt
Can't reproduce with revision #291411 rar extension.

Tested with a RAR archive containing 512 files on windows.

Not much I can do, so closing the bug.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Aug 19 16:01:27 2019 UTC