php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57027 configure error
Submitted: 2006-05-20 02:12 UTC Modified: 2006-05-20 09:05 UTC
From: nikolay_b at list dot ru Assigned:
Status: Not a bug Package: memcache (PECL)
PHP Version: 5.1.2 OS: FreeBSD 5.4
Private report: No CVE-ID: None
 [2006-05-20 02:12 UTC] nikolay_b at list dot ru
Description:
------------
configure error.
It's bug?
Please, help!

Reproduce code:
---------------
/data/server/bin/phpize --clean
/data/server/bin/phpize
./configure --with-php-config=/data/server/bin/php-config --enable-memcache --with-zlib-dir=/usr/lib
Configuring for:
PHP Api Version:         20031224
Zend Module Api No:      20041030
Zend Extension Api No:   220040412
creating cache ./config.cache
checking host system type... i386-unknown-freebsd5.4
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... yes
checking for PHP prefix... /data/server/local/www
checking for PHP includes... -I/data/server/local/www/include/php -I/data/server/local/www/include/php/main -I/data/server/local/www/include/php/TSR
M -I/data/server/local/www/include/php/Zend
checking for PHP extension directory... /data/server/local/www/lib/php/extensions/no-debug-non-zts-20041030
checking for re2c... exit 0;
checking for mawk... no
checking for gawk... no
checking for nawk... nawk
: not found
checking whether to enable memcache support... yes, shared
: not found
: not found
./configure: 1375: Syntax error: "elif" unexpected (expecting "then")
Press any key to continue...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-20 09:05 UTC] tony2001 at phpclub dot net
Duplicate of bug #7631.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 19:03:40 2021 UTC