php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57016 Apache does not start with memcache 2.0.3
Submitted: 2006-05-15 23:32 UTC Modified: 2007-10-17 16:18 UTC
From: jplock at gmail dot com Assigned:
Status: No Feedback Package: memcache (PECL)
PHP Version: 5.1.4 OS: Solaris 9
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-05-15 23:32 UTC] jplock at gmail dot com
Description:
------------
When starting Apache 1.3.35 with PHP 5.1.4 on Solaris 9, I'm getting the following error after upgrading from memcache 2.0.1 to 2.0.3:

ld.so.1: httpd: fatal: relocation error: file /usr/local/lib/php/extensions/no-debug-non-zts-20050922/memcache.so: symbol OnUpdateInt: referenced symbol not found

Digging on google found this thread:

http://beeblex.com/lists/index.php/php.pecl.dev/3633?s=l%3Aphp.pecl.dev

Which talks about using OnUpdateBool instead of OnUpdateInt on Solaris, I'm not sure if that would help or not though as I didn't look through the code.

Any help would be appreciated. Thanks.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-15 23:38 UTC] jplock at gmail dot com
This was upgraded using: pecl upgrade memcache
 [2006-05-16 08:37 UTC] blade106 at free dot fr
Same problem here on PHP 5.1.4 too.

Running on Apache 2.2.2 and Linux debian (stable), with eAccelerator enabled.

Tried to compile it myself, same thing.
 [2006-05-16 08:57 UTC] blade106 at free dot fr
Tried 2.0.2 => same problem again

Tried 2.0.1 => seems to work fine with a little php test-file :)

I've read some pages that deals with OnUpdateLong versus OnUpdateInt, is that the problem here ?
 [2006-05-16 15:17 UTC] mikael at synd dot info
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/memcache


 [2006-05-16 16:32 UTC] jplock at gmail dot com
Now I get this:

[16-May-2006 16:25:46] PHP Warning:  PHP Startup: Invalid library (maybe not a PHP library) 'memcache.so'  in Unknown on line 0

After doing pecl upgrade memcache on Solaris 9. Compiled fine though.
 [2006-05-17 04:48 UTC] blade106 at free dot fr
Worked for me :) Thanks a lot for this quick update !
 [2006-09-06 08:00 UTC] mikael at synd dot info
I can't reproduce this problem and searching the bug database for "PHP Startup: Invalid library" leads me to belive it's some sort of problem with your build. 

Would you mind trying "pear install --force memcache" as well as checking that "extension_dir" in php.ini points to the dir where "pear install" puts the library, I've encountered this error when trying to load stale extensions (compiled for a previous non-compatible php build)

//Mikael
 [2007-10-17 16:18 UTC] mikael at synd dot info
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 22:03:34 2021 UTC