php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56990 Does not build with automake 1.9
Submitted: 2006-04-28 11:24 UTC Modified: 2009-01-11 16:23 UTC
From: jwarnier at beeznest dot net Assigned:
Status: Not a bug Package: ssh2 (PECL)
PHP Version: 4.3.10 OS: Linux
Private report: No CVE-ID: None
 [2006-04-28 11:24 UTC] jwarnier at beeznest dot net
Description:
------------
The extension does not build with the following error of autoconf when trying to build with automake 1.9.

Hope it helps.

php-ssh2-0.10/ssh2-0.10$ autoconf
autoconf: Undefined macros:
***BUG in Autoconf--please report*** AC_DEFINE
***BUG in Autoconf--please report*** AC_DEFINE
***BUG in Autoconf--please report*** AC_MSG_WARN
***BUG in Autoconf--please report*** AC_DEFINE
***BUG in Autoconf--please report*** AC_MSG_WARN
***BUG in Autoconf--please report*** AC_DEFINE
***BUG in Autoconf--please report*** AC_MSG_WARN
***BUG in Autoconf--please report*** AC_DEFINE
***BUG in Autoconf--please report*** AC_MSG_WARN
configure.in:20:    AC_MSG_ERROR(Cannot find php-config. Please use --with-php-config=PATH)
configure.in:63:AC_PROG_LIBTOOL

Expected result:
----------------
It should not spit any errors, and just work.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-11 14:07 UTC] mikesul@php.net
Sorry, but your problem does not imply a bug in PECL itself.  For a
list of more appropriate places to ask for help using PECL, please
visit http://pecl.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PECL.

You may also want to make sure your build tools work and try the latest release.
 [2009-01-11 14:40 UTC] jwarnier at beeznest dot net
You will probably understand I don't even remember the reason why I submitted to PECL and nowhere else.
In the meantime, I don't even use php-ssh anymore.
As a result, you may safely close this bug.

Thanks for caring.
 [2009-01-11 16:23 UTC] mikesul@php.net
Fair enough. I've only recently picked up the extension, but I'm trying to give the old bug reports some care. :)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Sep 21 13:01:27 2019 UTC