php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56988 Install PEAR with "go-pear.php"
Submitted: 2006-04-27 18:11 UTC Modified: 2006-06-21 06:36 UTC
From: mylist at terra dot com dot br Assigned: pajoye (profile)
Status: Not a bug Package: PECL website (PECL)
PHP Version: 4.4.2 OS: Linux
Private report: No CVE-ID: None
 [2006-04-27 18:11 UTC] mylist at terra dot com dot br
Description:
------------
Hi, 

 When I try install PEAR, using "go-pear.php" remotely on my webhosting server, it response with this message:

========================
Warning: main(PEAR.php): failed to open stream: No such file or directory in /mydir/myuser/pear/go-pear.php on line 659

Warning: main(): Failed opening 'PEAR.php' for inclusion (include_path='gopej6SDXe') in /mydir/myuser/pear/go-pear.php on line 659

ok
Bootstrapping: Archive_Tar............(remote) ok
Bootstrapping: Console_Getopt.........(remote) ok

Fatal error: Undefined class name 'pear' in /mydir/myuser/pear/go-pear.php on line 713
========================

   But, after the problem have ocurred, i reload there site, it complete sucessfull. 

   There problem it's possible related whith "tmp_dir" location.

   - Knorst

:: Sorry for my english.

   



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-27 18:49 UTC] pajoye@php.net
It was maybe the problem, sometimes ISP have weird permissions settings...

Does it work now or not?
 [2006-04-28 10:50 UTC] mylist at terra dot com dot br
Hi,

 My ISP runs PHP as CGI with Safe Mode "ON".

 So, the execution permissions are OK on the server on which these scripts run.

 It's strange, because, the first execution does not work, but the second does.

 Besides, during the installation procedure, a directory with the name "<my instaldir>/$prefix/temp" is created.

 Is this correct ???

 Regards.
 [2006-04-28 11:12 UTC] pajoye@php.net
Being in safe_mode does not make your permissions any better, it is often even worst :)

However, I think you found the right problem. Can you try this file to install:
http://pear.php.net/~pierre/gopear.txt

Save it under gopear.php and run it. It should fix your problem (and a couple of other).
 [2006-04-28 13:37 UTC] mylist at terra dot com dot br
Hi, 

 No, Not Solved, the problem persists!

 Regards,
 [2006-04-28 13:40 UTC] pajoye@php.net
Which?

I was talking about:

"<my instaldir>/$prefix/temp" is created.

Is it still the case? Do you still get the warnings about (PEAR.php)?
 [2006-04-28 14:47 UTC] mylist at terra dot com dot br
Hi, 

 With the system's new version, the "<my instaldir>/$prefix/temp" directory is no longer created.

 However, the initial problem remains.

 Besides, the following warnings occurred:

=============
warning: pear/PEAR requires package "pear/Archive_Tar" (version >= 1.3.1)
warning: pear/PEAR requires package "pear/Console_Getopt" (version >= 1.2)
pear/PEAR can optionally use package "pear/XML_RPC" (version >= 1.4.0)
pear/PEAR can optionally use package "pear/PEAR_Frontend_Web" (version >= 0.5.0)
pear/PEAR can optionally use package "pear/PEAR_Frontend_Gtk" (version >= 0.4.0)
=============

  Should I worry about them?

  What do they mean?

  Regards,
 [2006-04-28 14:49 UTC] mylist at terra dot com dot br
:: The warnings occur on the second execution.
 [2006-04-28 14:53 UTC] pajoye@php.net
They are installer warnings. They are displayed when you install a package, to inform you about possible troubles but are usually not critical.

So yes, you can ignore them, they are normal in the go-pear install.

Besides these warnings, any other troubles?
 [2006-04-28 15:22 UTC] mylist at terra dot com dot br
Hi,

  I have found a possible solution !!

  When, I create manually the directory "<my instaldir>/temp" before the execution, then, the instalation work fine.

  But, occur a warning: "System's Tempdir failed, trying to use $prefix/tmp ...ok".

  So, my initial suspect are correctly.
  The bug it's on the manipulation of "$prefix/temp".

  Regards
 [2006-04-28 16:22 UTC] pajoye@php.net
Fetch again the script from the link I gave you. It should fix the problem.
 [2006-04-28 16:51 UTC] mylist at terra dot com dot br
Hi, 

  This problem with "tmp_dir" have resolved.

  But, now occur another problem:

==============================
...
pear/PEAR can optionally use package "pear/XML_RPC" (version >= 1.4.0)
pear/PEAR can optionally use package "pear/PEAR_Frontend_Web" (version >= 0.5.0)
pear/PEAR can optionally use package "pear/PEAR_Frontend_Gtk" (version >= 0.4.0)
install ok: channel://pear.php.net/PEAR-1.4.9
downloading Archive_Tar-1.3.1.tgz ...
Could not download from "http://pear.php.net/get/Archive_Tar-1.3.1.tgz", cannot download "pear/Archive_Tar"
Error: cannot download "pear/Archive_Tar"
downloading Console_Getopt-1.2.tgz ...
Could not download from "http://pear.php.net/get/Console_Getopt-1.2.tgz", cannot download "pear/Console_Getopt"
Error: cannot download "pear/Console_Getopt"
downloading XML_RPC-1.4.8.tgz ...
Could not download from "http://pear.php.net/get/XML_RPC-1.4.8.tgz", cannot download "pear/XML_RPC"
Error: cannot download "pear/XML_RPC"
downloading HTML_Template_IT-1.1.4.tgz ...
Could not download from "http://pear.php.net/get/HTML_Template_IT-1.1.4.tgz", cannot download "pear/HTML_Template_IT"
Error: cannot download "pear/HTML_Template_IT"
downloading Net_UserAgent_Detect-2.2.0.tgz ...
Could not download from "http://pear.php.net/get/Net_UserAgent_Detect-2.2.0.tgz", cannot download "pear/Net_UserAgent_Detect"
Error: cannot download "pear/Net_UserAgent_Detect"
warning: pear/PEAR_Frontend_Web requires package "pear/Net_UserAgent_Detect"
warning: pear/PEAR_Frontend_Web requires package "pear/HTML_Template_IT"
downloading PEAR_Frontend_Web-0.5.1.tgz ...
Could not download from "http://pear.php.net/get/PEAR_Frontend_Web-0.5.1.tgz", cannot download "pear/PEAR_Frontend_Web"
Error: cannot download "pear/PEAR_Frontend_Web"
Writing WebFrontend file ...
Warning: 

copy(/mydir/myuser/pear/PEAR/docs/PEAR_Frontend_Web/docs/example.php): failed to open stream: No such file or directory in /mydir/myuser/pear/gopear.php on line 903

==============================

  Regards
 [2006-04-28 18:37 UTC] pajoye@php.net
Ok, now you have another problem not really related to gopear.

I can help to figure it out if you give me an access to your host, ftp or SSH. You can mail me it to pierre.php@gmail.com. If not, I see little hope to solve your problem without having an access.
 [2006-05-02 13:59 UTC] mylist at terra dot com dot br
Hi, 

  I send for you, but, in Private.

  Regard's 
   - Knorst
 [2006-06-21 03:05 UTC] sunnuchowdhary at gmail dot com
hi,
I m sushma working on php with o/s as linux-suse10.0..i wanted to install pear but i m not finding the correct steps ..so please help me out by providing the steps to install pear in Linux
 [2006-06-21 06:36 UTC] pierre dot php at gmail dot com
Sorry, but your problem does not imply a bug in PECL itself.  For a
list of more appropriate places to ask for help using PECL, please
visit http://pecl.php.net/support/ as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PECL.

Please use the pear-general mailing list to ask support question. See http://pear.php.net/support/lists.php
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Jan 26 10:01:23 2021 UTC