php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56985 'ze_zip_object' has no member named 'std'
Submitted: 2006-04-27 12:54 UTC Modified: 2006-04-27 13:07 UTC
From: Fedora at FamilleCollet dot com Assigned: pajoye (profile)
Status: Not a bug Package: zip (PECL)
PHP Version: 5.1.2 OS: Fedora
Private report: No CVE-ID: None
 [2006-04-27 12:54 UTC] Fedora at FamilleCollet dot com
Description:
------------
Error at compile of new version 1.3.0

/home/extras/BUILD/zip-1.3.0/php_zip.c: In function 'php_zip_object_free_storage':
/home/extras/BUILD/zip-1.3.0/php_zip.c:464: error: 'ze_zip_object' has no member named 'std'
/home/extras/BUILD/zip-1.3.0/php_zip.c:465: error: 'ze_zip_object' has no member named 'std'
/home/extras/BUILD/zip-1.3.0/php_zip.c:469: error: 'ze_zip_object' has no member named 'std'
/home/extras/BUILD/zip-1.3.0/php_zip.c:470: error: 'ze_zip_object' has no member named 'std'



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-27 12:59 UTC] Fedora at FamilleCollet dot com
Probably a problem with version detection.
Here a patch i use to build this version :
--- php_zip.c.orig      2006-04-27 18:55:24.000000000 +0200
+++ php_zip.c   2006-04-27 18:55:29.000000000 +0200
@@ -457,7 +457,7 @@

        intern->za = NULL;

-#if (PHP_MAJOR_VERSION == 5 && PHP_MINOR_VERSION == 1 && PHP_RELEASE_VERSION > 2) || (PHP_MAJOR_VERSION == 5 && PHP_MINOR_VERSION > 1) || (PHP_MAJOR_VERSION > 5)
+#if (PHP_MAJOR_VERSION == 5 && PHP_MINOR_VERSION == 1 && PHP_RELEASE_VERSION > 1) || (PHP_MAJOR_VERSION == 5 && PHP_MINOR_VERSION > 1) || (PHP_MAJOR_VERSION > 5)
        zend_object_std_dtor(&intern->zo TSRMLS_CC);
 #else
        if (intern->zo.guards) {
 [2006-04-27 13:07 UTC] pierre dot php at gmail dot com
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PECL.

Fixed in 1.3.1. Marked as duplicated #7500
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jul 06 20:01:04 2020 UTC