php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56926 core dump
Submitted: 2006-03-29 06:20 UTC Modified: 2006-04-12 12:52 UTC
From: uros at sir-mag dot com Assigned: mike (profile)
Status: Closed Package: pecl_http (PECL)
PHP Version: 5.1.1 OS: FreeBSD
Private report: No CVE-ID: None
 [2006-03-29 06:20 UTC] uros at sir-mag dot com
Description:
------------
In my script runnig with php-cli i use http request and script works for about 5 - 10 minutes that core dumps

this is bt if it helps. I don't know if it's about peclhttp but in scripts without this code I don't get any core dumps.

#0  0x081050ea in zend_update_property_string ()
(gdb) bt
#0  0x081050ea in zend_update_property_string ()
#1  0x28d905f9 in _http_request_object_responsehandler (obj=0x85f068c, this_ptr=0x847806c) at /tmp/tmpJGDWG0/pecl_http-1.0.0RC2/http_request_object.c:636
#2  0x28d94115 in zif_HttpRequest_send (ht=0, return_value=0x89926ec, this_ptr=0x847806c, return_value_used=1)
    at /tmp/tmpJGDWG0/pecl_http-1.0.0RC2/http_request_object.c:2080
#3  0x08128682 in zend_do_fcall_common_helper ()
#4  0x08128adf in zend_do_fcall_by_name_handler ()
#5  0x0811eb41 in execute ()
#6  0x08100944 in zend_execute_scripts ()
#7  0x080cec46 in php_execute_script ()
#8  0x08130900 in main ()



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-29 07:41 UTC] mike@php.net
Thanks for your report. I'd need a reproduce script though.

Thank you
 [2006-03-29 07:58 UTC] uros at sir-mag dot com
Huh. It's a huge script. Can I send it to you directly. I don't want to expose it here.
 [2006-03-29 08:06 UTC] mike@php.net
Yes, please do so. Use mike at iworks.at
 [2006-03-29 10:22 UTC] mike@php.net
I can't reproduce myself, and I can't use your script as it has too many external dependencies.

A backtrace with function argument info would probably help, too.
 [2006-03-29 13:17 UTC] uros at sir-mag dot com
Can you please tell me how to make such backtrace. I'm not good with debuger.
 [2006-03-29 14:06 UTC] mike@php.net
You'll probably need a PHP build with more debugging information (preferable compiled with --enable-debug).

Note that you can always build and install more php binaries at once, just choose a different prefix:

$ cvs -z6 -d:pserver:cvsread@cvs.php.net:/repository login
Password: phpfi
$ cvs -z6 -d:pserver:cvsread@cvs.php.net:/repository \
    checkout -d php-5.1 -r PHP_5_1 php-src
$ cvs -z6 -d:pserver:cvsread@cvs.php.net:/repository \
    checkout pecl/http
$ cd php-5.1
$ ln -s ../pecl/http ext/http
$ ./buildconf
$ ./configure \
    --prefix=/tmp/php5 \
    --enable-debug \
    --enable-http \
    --other-options
$ make
$ make install

Now this debug build binary should be located at /tmp/php5/bin/php. Try that one to execute your script.

Thank you ;)
 [2006-04-12 12:52 UTC] mike@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 06:03:37 2021 UTC