php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56911 APD cannot compile into the PHP core
Submitted: 2006-03-23 19:08 UTC Modified: 2013-07-31 03:08 UTC
From: mattsch at gmail dot com Assigned:
Status: Not a bug Package: apd (PECL)
PHP Version: 5_1 CVS-2006-03-23 OS: Gentoo
Private report: No CVE-ID: None
 [2006-03-23 19:08 UTC] mattsch at gmail dot com
Description:
------------
APD does not compile when trying to build it into the php core.  

php stops compiling with this error:

/bin/sh /usr/src/php-5.1.2/libtool --silent --preserve-dup-deps --mode=compile gcc  -I/usr/include/apache2  -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE -I/usr/include/apr-0   -I/usr/include/apr-0 -I/usr/include/db4.2 -Isapi/apache2handler/ -I/usr/src/php-5.1.2/sapi/apache2handler/ -DPHP_ATOM_INC -I/usr/src/php-5.1.2/include -I/usr/src/php-5.1.2/main -I/usr/src/php-5.1.2 -I/usr/include/libxml2 -I/usr/src/php-5.1.2/ext/date/lib -I/usr/include/freetype2 -I/usr/src/php-5.1.2/ext/mbstring/oniguruma -I/usr/src/php-5.1.2/ext/mbstring/libmbfl -I/usr/src/php-5.1.2/ext/mbstring/libmbfl/mbfl -I/usr/include/mysql -I/usr/lib/odbtp/include -I/usr/include/pspell -I/usr/src/php-5.1.2/TSRM -I/usr/src/php-5.1.2/Zend    -I/usr/include -g -O2  -prefer-non-pic -c /usr/src/php-5.1.2/sapi/apache2handler/php_functions.c -o sapi/apache2handler/php_functions.lo
/bin/sh /usr/src/php-5.1.2/libtool --silent --preserve-dup-deps --mode=compile gcc  -Imain/ -I/usr/src/php-5.1.2/main/ -DPHP_ATOM_INC -I/usr/src/php-5.1.2/include -I/usr/src/php-5.1.2/main -I/usr/src/php-5.1.2 -I/usr/include/libxml2 -I/usr/src/php-5.1.2/ext/date/lib -I/usr/include/freetype2 -I/usr/src/php-5.1.2/ext/mbstring/oniguruma -I/usr/src/php-5.1.2/ext/mbstring/libmbfl -I/usr/src/php-5.1.2/ext/mbstring/libmbfl/mbfl -I/usr/include/mysql -I/usr/lib/odbtp/include -I/usr/include/pspell -I/usr/src/php-5.1.2/TSRM -I/usr/src/php-5.1.2/Zend    -I/usr/include -g -O2  -prefer-non-pic -c main/internal_functions.c -o main/internal_functions.lo
In file included from /usr/src/php-5.1.2/ext/standard/fsock.h:30,
                 from /usr/src/php-5.1.2/ext/standard/php_standard.h:44,
                 from main/internal_functions.c:67:
main/php_network.h:210: error: conflicting types for `php_sockaddr_storage'
/usr/src/php-5.1.2/ext/apd/php_sockets.h:108: error: previous declaration of `php_sockaddr_storage'
make: *** [main/internal_functions.lo] Error 1


Reproduce code:
---------------
Here's my configure:

./configure --prefix=/usr/lib/php --with-apxs2=/usr/sbin/apxs2 --with-openssl --with-zlib --with-bz2 --enable-calendar --enable-bcmath --with-curl=/usr/include/curl --enable-exif --enable-filepro --enable-ftp --with-ttf --enable-mbstring --enable-zend-multibyte --without-mysql --with-mysqli=/usr/bin/mysql_config --with-mysql-sock=/var/run/mysqld/mysqld.sock --enable-sockets --enable-sqllite-utf8 --enable-wddx --with-gettext=/usr/lib/gettext  --with-magickwand=/usr --with-mcrypt --with-mhash --with-gd --with-jpeg-dir --with-png-dir --with-freetype-dir --with-zlib-dir --with-libxml-dir --with-mime-magic=/etc/apache2/magic --with-pear --with-fileinfo --with-pspell=/usr --disable-posix --with-bzip2=/usr --with-odbtp-mssql=/usr/lib/odbtp --with-config-file-path=/etc --with-tidy --enable-force-cgi-redirect --enable-apd

Expected result:
----------------
APD should compile into the php core.

Actual result:
--------------
APD cannot compile into the core and can only compile by itself.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-07-31 03:08 UTC] yohgaki@php.net
-Status: Open +Status: Not a bug
 [2013-07-31 03:08 UTC] yohgaki@php.net
I suppose APD development is not active.
 [2019-01-02 17:41 UTC] chealer at gmail dot com
yohgaki, why was this set to Status Not a bug?
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Sep 25 08:01:25 2020 UTC