php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56910 XMLReader segfaults apache
Submitted: 2006-03-23 18:10 UTC Modified: 2008-05-04 12:49 UTC
From: lateralus at nutextonline dot com Assigned:
Status: Not a bug Package: xmlReader (PECL)
PHP Version: 5.0.5 OS: RHEL3
Private report: No CVE-ID: None
 [2006-03-23 18:10 UTC] lateralus at nutextonline dot com
Description:
------------
After updating to XMLReader CVS (HEAD, and later I tried RELEASE_1_0_4) apache segfaults. I'm running RHEL3, using PHP 5.0.5, and Apache/1.3.33 with libxml2-2.6.10. 

There are no errors or warnings during the build of XMLReader.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-23 20:05 UTC] pierre dot php at gmail dot com
Can you provide a small script and a xml data to reproduce this problem?
 [2006-03-23 20:20 UTC] pierre dot php at gmail dot com
I forgot to mention (thanks Rob) that you cannot use HEAD for 5.0.
 [2006-03-28 14:54 UTC] lateralus at nutextonline dot com
Should have stated this sooner, the segfault does not occur when a script is ran but rather when I try to start apache.
 [2008-05-04 12:49 UTC] rrichards@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PECL.

.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 08:01:26 2019 UTC