php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56901 Needs CFLAGS=-ldevstat for ./configure
Submitted: 2006-03-19 14:36 UTC Modified: 2006-03-21 22:39 UTC
From: sean@php.net Assigned:
Status: Closed Package: statgrab (PECL)
PHP Version: 5_1 CVS-2006-03-19 OS: FreeBSD
Private report: No CVE-ID: None
 [2006-03-19 14:36 UTC] sean@php.net
Description:
------------
Please adjust the configure.m4 to do:
CFLAGS=-ldevstat ./configure
on FreeBSD.

configure (without cflags) ends in:
checking for sg_init in -lstatgrab... no
configure: error: wrong libstatgrab version or lib not found, Statgrab version 0.10+ is required.

config.log excerpt:
configure:2751: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -lm conftest.c -lstatgrab   1>&5
/usr/local/lib/libstatgrab.so: undefined reference to `devstat_selectdevs'
/usr/local/lib/libstatgrab.so: undefined reference to `devstat_getdevs'
configure: failed program was:
#line 2740 "configure"
#include "confdefs.h"

(Rasmus found this solution)

S



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-21 22:39 UTC] ilia at prohost dot org
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Dec 05 03:01:23 2020 UTC