php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56886 configure: error: libtool configure failed
Submitted: 2006-03-09 18:27 UTC Modified: 2008-07-01 12:28 UTC
From: monte dot shaffer at gmail dot com Assigned:
Status: Not a bug Package: xdiff (PECL)
PHP Version: 4.3.9 OS: FreeBSD 5.3-RELEASE (GENERIC)
Private report: No CVE-ID: None
 [2006-03-09 18:27 UTC] monte dot shaffer at gmail dot com
Description:
------------
# cd /path/to/xdiff-1.4
# ./configure
ltconfig: you must specify a host type if you use `--no-verify'
Try `ltconfig --help' for more information.
configure: error: libtool configure failed

# locate libtool
/path/to/xdiff-1.4/libtool
/usr/local/bin/libtool13
/usr/local/bin/libtool15
/usr/local/bin/libtoolize13
/usr/local/bin/libtoolize15

INSTALL BASED on instructions: http://us3.php.net/xdiff

gunzip xdiff-xxx.tgz
tar -xvf xdiff-xxx.tar
cd xdiff-xxx
phpize
./configure && make && make install


PEAR is not installed.

Reproduce code:
---------------
./configure
checking build system type... i386-unknown-freebsd5.3
checking host system type... i386-unknown-freebsd5.3
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... yes
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM
checking for PHP extension directory... /usr/local/lib/php/20020429
checking for re2c... exit 0;
checking for gawk... no
checking for mawk... no
checking for nawk... nawk
checking for xdiff support... yes, shared
checking for xdiff files in default path... found in /usr/local
checking for dlopen in -ldl... no
checking for xdl_diff in -lxdiff... yes
checking for xdl_set_allocator in -lxdiff... yes
checking for ranlib... ranlib
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
loading cache /dev/null within ltconfig
ltconfig: you must specify a host type if you use `--no-verify'
Try `ltconfig --help' for more information.
configure: error: libtool configure failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-01 12:28 UTC] mg at iceni dot pl
Sorry, but your problem does not imply a bug in PECL itself.  For a
list of more appropriate places to ask for help using PECL, please
visit http://pecl.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PECL.

It seems to be an issue with php extension build system, not package itself.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 14 16:01:42 2019 UTC