php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56857 linking fails
Submitted: 2006-02-24 08:06 UTC Modified: 2006-02-24 09:36 UTC
From: indeyets at gmail dot com Assigned: mike (profile)
Status: Closed Package: pecl_http (PECL)
PHP Version: 5.1.1 OS: MacOS X 10.4
Private report: No CVE-ID: None
 [2006-02-24 08:06 UTC] indeyets at gmail dot com
Description:
------------
after typing "pecl install pecl_http" extension compiles mostly fine, until:

/bin/sh /private/var/tmp/pear-build-indy/pecl_http-0.24.1/libtool --mode=link gcc -DPHP_ATOM_INC -I/private/var/tmp/pear-build-indy/pecl_http-0.24.1/include -I/private/var/tmp/pear-build-indy/pecl_http-0.24.1/main -I/private/tmp/tmp2gobRy/pecl_http-0.24.1 -I/sw/local/include/php -I/sw/local/include/php/main -I/sw/local/include/php/TSRM -I/sw/local/include/php/Zend -I/sw/local/include/php/ext  -I/sw/local/include -L/sw/include -L/usr/local/include -L/usr/include -DHAVE_CONFIG_H  -g -O2  -L/sw/local/lib -L/sw/lib -L/usr/local/lib -L/usr/lib -o http.la -export-dynamic -avoid-version -prefer-pic -module -rpath /private/var/tmp/pear-build-indy/pecl_http-0.24.1/modules  missing.lo http.lo http_functions.lo phpstr/phpstr.lo http_util_object.lo http_message_object.lo http_request_object.lo http_request_pool_api.lo http_response_object.lo http_exception_object.lo http_requestpool_object.lo http_api.lo http_cache_api.lo http_request_api.lo http_date_api.lo http_headers_api.lo http_message_api.lo http_send_api.lo http_
url_api.lo http_info_api.lo http_request_method_api.lo http_encoding_api.lo http_filter_api.lo http_request_body_api.lo http_querystring_object.lo http_deflatestream_object.lo http_inflatestream_object.lo http_cookie_api.lo -lcurl -lz -lcurl -lssl -lcrypto -lz
gcc ${wl}-flat_namespace ${wl}-undefined ${wl}suppress -o .libs/http.so -bundle  .libs/missing.o .libs/http.o .libs/http_functions.o phpstr/.libs/phpstr.o .libs/http_util_object.o .libs/http_message_object.o .libs/http_request_object.o .libs/http_request_pool_api.o .libs/http_response_object.o .libs/http_exception_object.o .libs/http_requestpool_object.o .libs/http_api.o .libs/http_cache_api.o .libs/http_request_api.o .libs/http_date_api.o .libs/http_headers_api.o .libs/http_message_api.o .libs/http_send_api.o .libs/http_url_api.o .libs/http_info_api.o .libs/http_request_method_api.o .libs/http_encoding_api.o .libs/http_filter_api.o .libs/http_request_body_api.o .libs/http_querystring_object.o .libs/http_deflatestream_object.o .libs/http_inflatestream_object.o .libs/http_cookie_api.o  -L/sw/include -L/usr/local/include -L/usr/include -L/sw/local/lib -L/sw/lib -L/usr/local/lib -L/usr/lib -lcurl -lssl -lcrypto -lz

/usr/bin/ld: multiple definitions of symbol _http_filter_factory
.libs/http.o definition of _http_filter_factory in section (__DATA,__common)
.libs/http_filter_api.o definition of _http_filter_factory in section (__DATA,__data)
collect2: ld returned 1 exit status
make: *** [http.la] Error 1
ERROR: `make' failed



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-24 09:36 UTC] mike@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

You can fix that locally by prepending "extern " to "php_stream_filter_factory http_filter_factory;" in php_http_filter_api.h

Thanks.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 24 04:03:36 2021 UTC