php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56803 undefined symbol: core_globals_id
Submitted: 2006-01-26 16:35 UTC Modified: 2006-01-27 13:51 UTC
From: apcbug at fwd dot asfs dot de Assigned:
Status: Closed Package: APC (PECL)
PHP Version: 5.1.2 OS: Linux (Debian sarge)
Private report: No CVE-ID: None
 [2006-01-26 16:35 UTC] apcbug at fwd dot asfs dot de
Description:
------------
I tried to install APC 3.0.8 on a debian sarge server with apache 2.0.54 and PHP 5.1.2 (this version is missing in the drop down box of the bug report form).
I did the following:

[root@zeus:/usr/src/APC-3.0.8]$ phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20050922
Zend Extension Api No:   220051025
[root@zeus:/usr/src/APC-3.0.8]$ ./configure --enable-apc --enable-apc-mmap --with-apxs=/usr/bin/apxs2 --with-php-config=/usr/bin/php-config

(and so on...everything like described in the INSTALL file)
I also tried the configure without mmap, apxs an php-config.

My php.ini looks like this:
extension="apc.so"
apc.enabled=1
apc.shm_segments=1
apc.shm_size=90
apc.optimization=1
apc.num_files_hint=1000
apc.ttl=0
apc.gc_ttl=3600
apc.cache_by_default="On"
apc.filters=""
apc.mmap_file_mask=""
apc.slam_defense=0
apc.file_update_protection=2
apc.enable_cli=0
apc.max_file_size="1M"

After reload apache starts without any complains, but APC is not loaded.
Error log sais:
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/2005102
5/apc.so' - /usr/lib/php5/20051025/apc.so: undefined symbol: core_globals_id in
Unknown on line 0

Expected result:
----------------
PHP running with APC.

Actual result:
--------------
Error Log see above.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-26 19:15 UTC] apcbug at fwd dot asfs dot de
I could reproduce this problem with different php extensions.
So it doesn't seem to be an APC-specific problem.
Nevertheless I can't explain this behavior. :-(
 [2006-01-27 13:51 UTC] apcbug at fwd dot asfs dot de
Was a local problem on our server.
Sorry for any inconveniences.

For your information:
For some reason there were two different php versions installed which caused a conflict. I purged one of these php versions and compiled the extensions again without any problems.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Jan 29 08:05:53 2023 UTC