|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56774 Interferes with phpinfo
Submitted: 2006-01-14 02:01 UTC Modified: 2007-04-13 13:56 UTC
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: mattsch at gmail dot com Assigned:
Status: No Feedback Package: imagick (PECL)
PHP Version: 5_1 CVS-2006-01-14 OS: Gentoo
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-01-14 02:01 UTC] mattsch at gmail dot com
imagick compiles fine on php 5.1.2 but it breaks both phpinfo() and php -i. Also documented here:

Reproduce code:

or in the shell:

php -i

Expected result:
Output php information.

Actual result:
Does not output anything for phpinfo() and outputs partially for php -i with this error:


ImageMagick support => enabled
Magick Backend => ImageMagick
ImageMagick version => 6.2.5
PHP imagick version => 0.9.11
MaxRGB => 65535
Supported image formats => clipmask
*** glibc detected *** free(): invalid pointer: 0xbfdd7378 ***


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-21 09:56 UTC] s dot glgoger at cybernet dot ch
i've solved the problem on my side when i compiled ImageMagick with "--enable-embeddable".

If you use FreeBSD (any version): 
edit: /usr/ports/graphics/ImageMagick/Makefile
add around line 210 (before the "post-patch:")
  CONFIGURE_ARGS+= --enable-embeddable

now apache is not core dumping anymore when issueing phpinfo();

but command-line "php -i" again shows:
Segmentation fault (core dumped)

if i disable "" php -i works fine. no coredump.

my config:
system: FreeBSD 5.4-STABLE
port: ImageMagick- 
port: pecl-imagick-0.9.11_3
 [2006-05-08 11:30 UTC] baco at infomaniak dot ch
Same bug with PHP 5.1.4 on Debian Sarge 
Adding --enable-embeddable 
solve the issue with seg fault when phpinfo()
 [2007-04-13 11:48 UTC]
Can you try the latest release please.
 [2007-04-13 12:45 UTC] mattsch at gmail dot com
I think hell just froze over.  I can't believe someone actually updated this module.  Kudos for your effort but why bother at this point when it's evident that the people who maintain imagemagick have built their own module which has all the imagemagick functions translated from Magickwand for C?
 [2007-04-13 13:56 UTC]
Because not everyone has the latest ImageMagick installed which the module obviously requires, we intend to bring out a new OO API to replace this module in the forthcoming weeks.

Today's release was purely for maintenance.
 [2007-11-02 16:00 UTC] nof8 at mail dot ru
I have the same issue with FreeBSD6.1/PHP 5.2.4, either with or, so using magickwand instead of imagick is not a universal solution.
Compiling ImageMagick with --enable-embeddable doesn't help either, it just changes error message to:

MagickWand Backend Library => ImageMagickAssertion failed: ((SizeOfBlock(memory) % (4*sizeof(size_t))) == 0), function RelinquishMagickMemory, file magick/memory.c, line 591

and phpinfo() still doesn't work
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Apr 17 22:01:26 2024 UTC