php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56735 APC needs unicode update
Submitted: 2005-12-19 21:51 UTC Modified: 2017-07-24 21:43 UTC
From: kennyt@php.net Assigned:
Status: Wont fix Package: APC (PECL)
PHP Version: HEAD CVS-2005-12-19 OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-12-19 21:51 UTC] kennyt@php.net
Description:
------------
APC needs to be patched up to compile/work under PHP 6.

Reproduce code:
---------------
$ phpize; ./configure; make

Actual result:
--------------
"'struct bucket' has no member named 'arKey'" in apc_compile.c: 1918, 1955

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-19 21:53 UTC] rasmus@php.net
yeah, remind me in about a year.  There is no point in doing it yet.  The Unicode stuff is going to change 10 times before PHP 6 is anywhere near done.
 [2017-07-24 21:43 UTC] kalle@php.net
-Status: Suspended +Status: Wont fix
 [2017-07-24 21:43 UTC] kalle@php.net
APC has been discontinued, please use opcache included with PHP 5.5.0+ instead, thanks!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Oct 30 16:01:23 2020 UTC