php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56732 My wishlist doesn't work =(
Submitted: 2005-12-18 15:13 UTC Modified: 2006-11-03 13:36 UTC
From: techtonik@php.net Assigned: mj (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2005-12-18 15:13 UTC] techtonik@php.net
Description:
------------
My christmas wishlist doesn't work - it inserts these &amps; in URL and I can't get rid of them. =(

http://pear.php.net/wishlist.php/techtonik


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-18 08:15 UTC] pajoye@php.net
Sorry, but your problem does not imply a bug in PEAR itself.  For a
list of more appropriate places to ask for help using PEAR, please
visit http://pear.php.net/support/ as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PEAR.

It works here (3 different browsers)
 [2006-02-18 09:21 UTC] techtonik@php.net
It works, because I've changed the URL. =/

Try again and note that ampersands in URL are transformed to & 's.
 [2006-02-18 09:25 UTC] pajoye@php.net
what's the exact target url? (copy it here)
 [2006-02-18 09:41 UTC] pajoye@php.net
This bug has been fixed in CVS.

If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET).

If this was a problem with the pear.php.net website, the change should be live shortly.

Otherwise, the fix will appear in the package's next release.

Thank you for the report and for helping us make PEAR better.


 [2006-02-18 10:09 UTC] techtonik@php.net
Just edit your PEAR details to specify URL with a ampersands in wishlist field to see how it "works". I've just adjusted mine for you, but better check this overhtmlescaping yourself. 

http://pear.php.net/wishlist.php/techtonik
 [2006-02-18 10:10 UTC] techtonik@php.net
Ok.
 [2006-05-16 13:06 UTC] mikael at synd dot info
account-edit.php seems to quote the posted values before inserting into the database and wishlist.php outputs the quoted uri directly using header("Location: $url");

The result is that the browser is redirected to an uri where every & is quoted to &

A solution could be to use unhtmlentities() from http://www.php.net/htmlspecialchars in wishlist.php before the call to header('Location: ..')

Using 
http://pecl.php.net/wishlist.php/mikl

Expected
http://www.amazon.com/gp/registry/wishlist/3QP28R224S50N/103-4864265-6791821?reveal=unpurchased&filter=all&sort=priority&layout=standard&x=13&y=12

Actual
http://www.amazon.com/gp/registry/wishlist/3QP28R224S50N/103-4864265-6791821?reveal=unpurchased&filter=all&sort=priority&layout=standard&x=13&y=12
 [2006-10-06 08:41 UTC] mj@php.net
This seems to work for me (now).

techtonik, mikl:  Please change your wishlist URL on http://pear.php.net/account-edit.php?handle=<handle> and replace all &amp; with & there.  After that it should work properly.

And please give feedback here afterwards.
 [2006-11-03 10:57 UTC] mj@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2006-11-03 13:36 UTC] techtonik@php.net
Seems2BFixed.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 19:05:52 2022 UTC