php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56719 php_pdo_oci.dll can not load
Submitted: 2005-12-11 23:38 UTC Modified: 2007-06-28 16:28 UTC
From: sumphan dot kuammana at seagate dot com Assigned:
Status: Not a bug Package: PDO_OCI (PECL)
PHP Version: 5.1.1 OS: WIN XP SP2
Private report: No CVE-ID: None
 [2005-12-11 23:38 UTC] sumphan dot kuammana at seagate dot com
Description:
------------
PHP_PDO_OCI.dll can not load it. 

Reproduce code:
---------------
php_pdo_oci.dll can not load it.
but other pdo can.

Expected result:
----------------
i run phpinfo() and found 
php_pdo_oci.dll can not load.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-12 08:40 UTC] wez@php.net
Did you install Oracle?
 [2005-12-12 20:46 UTC] sumphan dot kuammana at seagate dot com
Thank you for response. 
I install oracle client 9.2. It is work properly.
Now I connect to oracle database by use php_pdo_odbc.dll
It is work,I can insert data, delete data and update data. then I try to down load php_pdo_oci.dll and php_pdo.dll from 
http://snaps.php.net/win32/PECL_5_0/php_pdo.dll
http://snaps.php.net/win32/PECL_5_0/php_pdo_oci.dll
and replace it in c:/PHP/ext/
I use extension php_oci8.dll is work too.
in php.ini file is below
doc_root ="C:/apache211/Apache2/cal_db"
extension_dir = "c:/PHP/ext/"
extension=php_pdo.dll
extension=php_pdo_firebird.dll
extension=php_pdo_mssql.dll
extension=php_pdo_mysql.dll
extension=php_pdo_oci.dll
extension=php_pdo_odbc.dll
extension=php_pdo_pgsql.dll
extension=php_pdo_sqlite.dll
I run phpinfo() and
Error Message show
PHP start up:unable to load dynamic library 'c:/PHP/ext/php_pdo_oci.dll' - The specified prodceudre could not be found.
I try to change / to be \. It is not work.

Now I have no idea to do it.
Please advise.
 [2005-12-12 21:54 UTC] wez@php.net
If you use the php_pdo_oci.dll and php_pdo.dll that come with PHP 5.1.1, does it work?
 [2005-12-12 22:32 UTC] sumphan dot kuammana at seagate dot com
I have tried , and It is again not work.
 [2005-12-12 22:51 UTC] sumphan dot kuammana at seagate dot com
I again install PHP5.1.1 .

Problem is still happen.
unable to load php_pdo_oci.dll
 [2006-03-16 04:04 UTC] r dot whitehead at gyrolan dot com
I have exactly the same problem, I have reinstalled and tried varying versions but nothing seems to work.  The following are examples of the error messsages created

PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/php/ext/php_pdo_oci.dll' - The specified procedure could not be found. in Unknown on line 0
PHP Warning:  PHP Startup: Invalid library (maybe not a PHP library) 'php_pdo_oci8.dll'  in Unknown on line 0
 [2006-03-28 15:01 UTC] jfowlie at navarik dot com
This is an issue, on a slightly different platform:

PHP 5.1.2 running as ISAPI module on IIS on Windows 2000 Server.

In my php.ini file I have:
extension=php_pdo.dll
extension=php_oci8.dll
extension=php_pdo_oci.dll
extension=php_pdo_oci8.dll
extension=php_pdo_pgsql.dll

All except php_pdo_oci and php_pdo_oci8 load.

I can use php_oci8 to connect to my Oracle database.
But I was wanting to use PDO.

PDO is working, as I have it running with Postgresql with php_pdo_pgsql.dll. 

Running get_loaded_extensions returns (amongst other things), but no pdo_oci or pdo_oci8:

    [23] => PDO
    [24] => oci8
    [25] => pdo_pgsql

I downloaded the latest dlls from:
http://pecl4win.php.net/list.php

I restarted IIS many times...
 [2006-09-12 05:44 UTC] a at a dot com
The problem remain with PHP 5.1.6 :(

Here the message :
PHP Warning:  PHP Startup: Invalid library (maybe not a PHP library) 'php_pdo_oci8.dll'  in Unknown on line 0
Apache/1.3.33 (Win32) PHP/5.1.6 running...

Thanks to fix it, we need PDO 4 Oracle for an important enterprise dev.
 [2006-11-08 04:35 UTC] axel dot azerty at laposte dot net
Same problem with this setup : 
Windows 2003 Server R2 (all patches applied)
PHP 5.2.0
Oracle 9i 9.2.0.1.1
Instant client 10g 10.2.0.2-20060508

Here 's the PATH env variable : 
C:\Program Files\Oracle\jre\1.3.1\bin;C:\Program Files\Oracle\jre\1.1.8\bin;c:\program files\sapdb\indep_prog\bin;c:\program Files\sapdb\indep_prog\pgm;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Microsoft SQL Server\80\Tools\BINN;C:\dev\php5.2;C:\dev\oracle\instantclient_10_2

I deleted the C:\oracle\ora92\bin  from PATH env variable in order to the Instant client to be used instead of.

When I run PHP from command line, same error message :

Warning: PHP Startup: Invalid library (maybe not a PHP library) 'php_pdo_oci8.dll'  in Unknown on line 0
 [2007-06-28 16:28 UTC] christopher dot jones at oracle dot com
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PEAR.

There are multiple reports in this bug, most of which appear to be installation issues and should be followed up in a support forum.  Many are old.

Two comments: 

1) php_pdo_oci8.dll is the same code as php_pdo_oci.dll.  You only want to enable one of them.  Having both enabled is bound to cause symbol conflicts. Php_pdo_oci.dll requires Oracle 10g libraries while php_pdo_oci8.dll will work with older libraries.  Regardless of the libraries used by PHP, both can be used to connect to databases of other versions (with some limitations)

2) There was a problem late last year with the way the DLLs were linked.  This was due to a compiler upgrade and was quickly resolved.

If anyone still has a problem and it is not a support issue, please log a new bug.
 [2008-05-13 12:14 UTC] jroze at gipsis dot fr
Hello there,

I also have this problem with the last stable 5.2.6 version.

extension_dir = "C:\php\ext\"
extension=php_oci8.dll
extension=php_pdo.dll
extension=php_pdo_oci.dll

PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\php\\ext\\php_pdo.dll' - the specified procedure could not be found.\r\n in Unknown on line 0

It works only if i get the php_pdo.dll file from PHP 5.2.0 provided with EasyPHP 2.0b.

Bizarre!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Nov 27 18:01:25 2020 UTC