|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56659 configure fails
Submitted: 2005-11-17 13:34 UTC Modified: 2006-10-30 06:25 UTC
From: matt at kynx dot org Assigned: cem (profile)
Status: Closed Package: SCA_SDO (PECL)
PHP Version: 5_1 CVS-2005-11-17 (dev) OS: Linux
Private report: No CVE-ID: None
 [2005-11-17 13:34 UTC] matt at kynx dot org
Installing SDO-0.6.0 via pear installer (or manually) fails on ./configure

It looks to me like it's tripping on dodgy windows-style line endings in the file (showing up as "^M" in vim) - removing them gets me a little further along, but alas, not all the way (dies on an "unexpected of file" - guess I haven't caught them all).

I realise configure is generated by phpize, but phpize seems to be doing fine with other pecl packages (I've installed PDO and bcompiler with it). Let me know if there's any info about my setup that would help. 

Reproduce code:
# pear install sdo-beta

Expected result:
SDO installs

Actual result:
downloading sdo-0.6.0.tgz ...
Starting to download sdo-0.6.0.tgz (219,346 bytes)
.............................................done: 219,346 bytes
170 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20050922
Zend Extension Api No:   220051025
building in /var/tmp/pear-build-root/sdo-0.6.0
running: /tmp/tmpanh2hQ/sdo-0.6.0/configure
creating cache ./config.cache


checking for PHP extension directory... /usr/lib/php5/lib/php/extensions/no-debug-non-zts-20050922
checking for re2c... re2c
checking for re2c version... 0.9.9 (ok)
checking for gawk... gawk
: command not found0.6.0/configure: line 2510:
checking sdo ... yes, shared
: command not found0.6.0/configure: line 2559:
: command not found0.6.0/configure: line 2560:
/tmp/tmpanh2hQ/sdo-0.6.0/configure: line 2825: syntax error near unexpected token `fi'
/tmp/tmpanh2hQ/sdo-0.6.0/configure: line 2825: `  fi'
`/tmp/tmpanh2hQ/sdo-0.6.0/configure' failed


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-18 07:13 UTC]
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PECL.

I've tried this with 5.1.0RC6, and I see no problem of this kind. Also I notice that the first of the error messages occurs BEFORE your configure starts to process the sdo section.

When you say there are CRLFs in "the file", do you mean in your copy of sdo/config.m4?  

Could you append (with line numbers) the relevant parts of your configure script?
 [2005-11-19 05:41 UTC] matt at kynx dot org
OK, tried again with PHP5.1RC6 and sdo from CVS and it all went fine. Sorry for the noise.
 [2005-11-19 06:23 UTC] matt at kynx dot org
Hrm... just tried again with my download of 0.6.0, as opposed to the CVS checkout, and am seeing the CRLF problems still. So maybe it's a problem with how that release was bundled up.

I've had a look at config.m4 from sdo-0.6.0.tgz and it does appear to have CRLFs line endings. If I strip them off before running phpize, configure will run fine. 

The relevant lines from my configure generated from the original config.m4 (there's _lots_ more, but this is what it chokes on):

   2510 ^M
   2513 echo $ac_n "checking sdo ""... $ac_c" 1>&6

   2559 ^M
   2560 ^M
   2561 if test "$PHP_SDO" != "no"; then^M
   2562 ^M
   2563 if test -z "$PHP_LIBXML_DIR"; then^M

   2817 ^M
   2819     else
   2820       { echo "configure: error: libxml2 version 2.6.11 or greater required." 1>&2; exit 1; }
   2821     fi
   2822 else ^M
   2823   { echo "configure: error: xml2-config not found. Please check your libxml2 installation." 1>&2; exit 1; }^M
   2825   fi
   2826 ^M
   2827 ^M

Other info that may be relevant:

$ phpize --version
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20050922
Zend Extension Api No:   220051025

$ autoconf --version
Autoconf version 2.13

$ automake --version
automake (GNU automake) 1.9.6
 [2005-11-21 05:05 UTC]
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at

With my levels of Linux / GNU tools / PEAR / etc. the PEAR install glides smoothly past this problem, but I agree we could do better. We'll make sure to always build the package on Linux from now on.
 [2007-06-12 10:11 UTC] thippeswamyks at yahoo dot com

I am trying to install on RHEL 3 PHP Version 5.2.3 i am getting an error 
checking for xml2-config path... /usr/bin/xml2-config
configure: error: libxml2 version 2.6.11 or greater required.

Please help me , thanks in advance
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Mon May 29 12:03:44 2023 UTC