php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56586 PDO::FETCH_CLASSTYPE isn't used
Submitted: 2005-10-09 21:10 UTC Modified: 2005-11-24 16:49 UTC
From: php dot net at sharpdreams dot com Assigned: wez (profile)
Status: Closed Package: PDO (PECL)
PHP Version: 5_1 CVS-2005-10-09 (dev) OS: Win32
Private report: No CVE-ID: None
 [2005-10-09 21:10 UTC] php dot net at sharpdreams dot com
Description:
------------
PDO::FETCH_CLASSTYPE is no longer used within the fetch() methods, thus, we are unable to fetch into a created class. It seems the entire section for other FETCH_ types is blocked off by a "RETVAL_FALSE;".

If they are indeed working, can you please provide an example here and in the manual?

Thanks.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-21 14:20 UTC] aledmb at gmail dot com
Im getting this too with PHP 5.0.5.
None of the PDO::FETCH_* constants is recognized.
 [2005-10-28 21:41 UTC] wez@php.net
This isn't a forum for asking questions; if you have a bug, we need some code that will allows us to reproduce the problem.
 [2005-10-28 21:44 UTC] php dot net at sharpdreams dot com
If PDO::FETCH_CLASSTYPE is indeed working as intended, then consider this a documentation "bug" in that the constant is defined and listed but no usage information is included.
 [2005-11-24 16:49 UTC] wez@php.net
I removed the constant from the docs.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Apr 18 09:01:27 2024 UTC