php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56531 Hardcoded usage of /tmp
Submitted: 2005-09-07 08:58 UTC Modified: 2006-03-09 19:53 UTC
From: pecl_bugs at elexer dot com Assigned:
Status: Closed Package: APC (PECL)
PHP Version: 5_0 CVS-2005-09-07 (dev) OS: Windows
Private report: No CVE-ID: None
 [2005-09-07 08:58 UTC] pecl_bugs at elexer dot com
Description:
------------
APC 3.0.8 for Windows seems to use an hardcoded path of /tmp/.  When using APC the system kept giving me errors like:

====
apc_fcntl_create: could not open /tmp/apc.lock.0
====

until i manually created this directory.

This resource is being referenced in apc_fcntl_win32.c which seems to hardcode this value (line 45).

Expected result:
----------------
Usage of the Windows default temp directory


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-16 10:30 UTC] screen at brainkrash dot com
Still an issue in PECL SNAP 200510160630
 [2006-02-22 15:22 UTC] mastabog at hotmail dot com
I can confirm it for APC-3.0.8 (the latest release as of this writing) ...
 [2006-02-22 15:31 UTC] mastabog at hotmail dot com
Sorry for my last entry ... dunno what I was thinking

The lastest CVS snap (today) still exhibits this problem. Apparently the apc_fcntl_win32.c file hasn't been updated since July 29 2005.
 [2006-03-09 19:53 UTC] edink at emini dot dk
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jan 16 20:03:36 2022 UTC