php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56525 encoding always set to UTF-8 in sdo_das_xml
Submitted: 2005-09-05 01:27 UTC Modified: 2006-10-30 06:57 UTC
From: lmpmbernardo at users dot sourceforge dot net Assigned: cem (profile)
Status: Closed Package: SCA_SDO (PECL)
PHP Version: 5_1 CVS-2005-09-05 (dev) OS: Windows 2000
Private report: No CVE-ID: None
 [2005-09-05 01:27 UTC] lmpmbernardo at users dot sourceforge dot net
Description:
------------
SDO_DAS_XML always uses encoding UTF-8 even when the initial sources have different encoding. Using setEncode() does not work either.

Reproduce code:
---------------
try {
    $xmldas = SDO_DAS_XML::create("letter.xsd");
    $xdoc = $xmldas->loadFromFile("letter.xml");
    print("Encoding is set to: ".$xdoc->getEncoding()."\n");
    $xdoc->setEncoding("ISO-8859-1");
    print("Encoding is set to: ".$xdoc->getEncoding()."\n");
} catch (SDO_TypeNotFoundException $e) {
    print ("Type is not defined in the xsd file");
} catch (SDO_DAS_XML_ParserException $e) {
    print ("Problem while parsing");
}


Expected result:
----------------
Encoding is set to: UTF-8
Encoding is set to: ISO-8859-1


Actual result:
--------------
Encoding is set to: UTF-8
Encoding is set to: UTF-8

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-05 05:18 UTC] cem@php.net
Looks like a block copy problem
 [2005-09-05 07:17 UTC] cem@php.net
I have fixed the error as seen, and now get/setEncoding will work as documented. 

I would point out, however, that we do not currently support multi-byte character sets.
 [2005-09-05 07:18 UTC] cem@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu May 23 23:01:26 2019 UTC