|
php.net | support | documentation | report a bug | advanced search | search howto | statistics | random bug | login |
PatchesPull RequestsHistoryAllCommentsChangesGit/SVN commits
[2000-07-19 05:31 UTC] tjw at tjw dot org
[2000-10-26 14:48 UTC] tjw at tjw dot org
[2001-01-08 15:31 UTC] cynic@php.net
|
|||||||||||||||||||||||||||
Copyright © 2001-2026 The PHP GroupAll rights reserved. |
Last updated: Sat Oct 10 08:00:02 2026 UTC |
./configure --with-apxs=/usr/local/apache/bin/apxs \ --with-mysql=/usr/local/mysql \ --enable-track-vars builds correctly, but will not load into apache: bash-2.04# apachectl start Syntax error on line 224 of /usr/local/apache_1.3.12/conf/httpd.conf: Cannot load /usr/local/apache_1.3.12/libexec/libphp4.so into server: /usr/local/apache_1.3.12/libexec/libphp4.so: undefined symbol: uncompress /usr/local/bin/apachectl start: httpd could not be started I thought it was a GD error, but configure --without-gd produced the same error. Here's what ldd has to say: bash-2.04# ldd /usr/local/apache/libexec/libphp4.so libgdbm.so.2 => /usr/lib/libgdbm.so.2 (0x4011b000) libdl.so.2 => /lib/libdl.so.2 (0x40122000) libresolv.so.2 => /lib/libresolv.so.2 (0x40125000) libm.so.6 => /lib/libm.so.6 (0x40133000) libcrypt.so.1 => /lib/libcrypt.so.1 (0x4014f000) libnsl.so.1 => /lib/libnsl.so.1 (0x4017c000) libc.so.6 => /lib/libc.so.6 (0x40191000) /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)