php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56498 mono 0.7 not compiling
Submitted: 2005-08-17 09:07 UTC Modified: 2017-04-01 20:55 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: php-bugs at bust dot ac Assigned: sterling
Status: Wont fix Package: mono (PECL)
PHP Version: 5_0 CVS-2005-08-17 (dev) OS: RH EL ES3
Private report: No CVE-ID:
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-08-17 09:07 UTC] php-bugs at bust dot ac
Description:
------------
I've tried both mono from rpm and from latest source 1.1.8.3, php-5.0.3 and latest stable snapshot. OS is RedHat Enterprise Linux ES 3. 


Expected result:
----------------
compile

Actual result:
--------------
following is output of make. 

[root@dev2 mono-0.7]# make
/bin/sh /usr/src/php5-STABLE-200508160841/ext/mono-0.7/libtool --mode=compile gcc  -I. -I/usr/src/php5-STABLE-200508160841/ext/mono-0.7 -DPHP_ATOM_INC -I/usr/src/php5-STABLE-200508160841/ext/mono-0.7/include -I/usr/src/php5-STABLE-200508160841/ext/mono-0.7/main -I/usr/src/php5-STABLE-200508160841/ext/mono-0.7 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -DHAVE_CONFIG_H  -g -O2   -c /usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c -o php_mono.lo
gcc -I. -I/usr/src/php5-STABLE-200508160841/ext/mono-0.7 -DPHP_ATOM_INC -I/usr/src/php5-STABLE-200508160841/ext/mono-0.7/include -I/usr/src/php5-STABLE-200508160841/ext/mono-0.7/main -I/usr/src/php5-STABLE-200508160841/ext/mono-0.7 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DHAVE_CONFIG_H -g -O2 -c /usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c  -fPIC -DPIC -o php_mono.lo
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `create_php_object':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:121: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:122: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `create_mono_object':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:140: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `property_read':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:194: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:200: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `property_write':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:220: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `php_call_mono_method_ex':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:260: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:261: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:266: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:266: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:284: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:292: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `types_match':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:360: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:361: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:362: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `lookup_mono_method_ex':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:391: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:392: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:393: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `create_signature':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:572: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:572: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:572: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:572: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:574: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:574: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:574: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:574: error: dereferencing pointer to incomplete type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `method_get':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:667: error: structure has no member named `arg_types'
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: At top level:
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:737: warning: initialization from incompatible pointer type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:739: warning: initialization from incompatible pointer type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:740: warning: initialization from incompatible pointer type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:743: warning: initialization from incompatible pointer type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:744: warning: initialization from incompatible pointer type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:746: warning: initialization from incompatible pointer type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:747: warning: initialization from incompatible pointer type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:748: warning: initialization from incompatible pointer type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:749: warning: initialization from incompatible pointer type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:751: warning: initialization from incompatible pointer type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:753: warning: initialization from incompatible pointer type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `object_new':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:797: warning: passing arg 3 of `zend_objects_store_put' from incompatible pointer type
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:797: error: too few arguments to function `zend_objects_store_put'
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `create_php_method':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:896: error: too few arguments to function `zend_objects_store_put'
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `zif_mono_load':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:984: error: `mono_defaults' undeclared (first use in this function)
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:984: error: (Each undeclared identifier is reported only once
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:984: error: for each function it appears in.)
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c: In function `zm_startup_mono':
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:1039: error: structure has no member named `arg_types'
/usr/src/php5-STABLE-200508160841/ext/mono-0.7/php_mono.c:1052: error: structure has no member named `arg_types'
make: *** [php_mono.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-06-01 05:10 UTC] adi41 at tlen dot pl
Is this project dead? This bug was submited two years ago and it looks like it wasn't fixed. I get exact same error when I'm trying to compile mono v0.7. I'm trying to use some C# dll's  net2.0 in php under freeBsd, is there an alternative to mono 0.7? Meaby I can help fix this bug? "dereferencing pointer to incomplete type" could it be caused by incompatibile version of mono? Also I think that it's strange that mono v0.2  generates the same error. Well, I'll try to fix it, but it want be easy so if enyone can give me some usefull info about mono0.7 that I can use to understand how it works, thanks.
 [2011-10-17 18:54 UTC] sterling@php.net
I'm no longer working on the project - so unless someone else picks it up - it's dead.
 [2017-04-01 20:55 UTC] tpunt@php.net
-Status: Assigned +Status: Wont fix
 [2017-04-01 20:55 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2003, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Fri Jul 28 08:01:47 2017 UTC