php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56495 PECL Rest includes all users
Submitted: 2005-08-17 03:56 UTC Modified: 2005-09-04 19:01 UTC
From: toby@php.net Assigned:
Status: Wont fix Package: PECL website (PECL)
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-08-17 03:56 UTC] toby@php.net
Description:
------------
The newly generated PECL REST API shows all users (even PEAR Web ones).

Reproduce code:
---------------
http://pecl.php.net/rest/m/

Expected result:
----------------
Only PECL devs.

Actual result:
--------------
All PEAR/PECL web users.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-17 16:12 UTC] klaus at capitalfocus dot org
This is because all PEAR account holders can also login to pecl. And I assume there are no accounts that are pecl-only at this time.
 [2005-09-04 19:01 UTC] cellog@php.net
We can't fix this unless every PECL user is somehow flagged as such in the users table or karma table, and I don't see any mass movement on the pecl end to make this happen ever.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 27 22:01:24 2020 UTC