php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56468 make fails
Submitted: 2005-07-26 15:56 UTC Modified: 2005-10-23 10:40 UTC
From: mark at accuros dot com Assigned:
Status: Not a bug Package: perl (PECL)
PHP Version: 5.0.3 OS: linux (debian testing)
Private report: No CVE-ID: None
 [2005-07-26 15:56 UTC] mark at accuros dot com
Description:
------------
Actually using php-5.0.4 / debian(testing) with perl installed from debs (perl-5.8.7)

Make fails. I am following the install instructions on the Zend website submitted by 'Dmitry'.

error returned on make:

/usr/bin/ld: cannot find -lperl
collect2: ld returned 1 exit status
make: *** [perl.la] Error 1
 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-11 02:14 UTC] kchen6 at gel dot ym dot edu dot tw
I got the same problem on debian.
I think that it cannot get libperl.so loaded properly.
Finally I solved it by adding a symbolic link /usr/lib/libperl.so to point to where libperl.so really is. It works for me. You may also want to try to get a new libperl.so by apt-get. 

-kb
 [2005-08-11 10:39 UTC] mark at accuros dot com
oops..  found a symlink to and old perl version that was no longer on the box.  Once I fixed that link, all worked perfectly.  Thanks to kchen6 at gel dot ym dot edu dot tw for the suggestion!
 [2005-10-23 10:40 UTC] mike@php.net
No bug -> bogus.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Mar 23 00:01:26 2019 UTC