|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56458 pop3 doesnt compile with PHP 4.3.x, 4.4.0
Submitted: 2005-07-21 19:17 UTC Modified: 2005-07-30 09:08 UTC
From: eflash at gmx dot net Assigned:
Status: Closed Package: POP3 (PECL)
PHP Version: 4.3.10 OS: all
Private report: No CVE-ID: None
 [2005-07-21 19:17 UTC] eflash at gmx dot net
Hi, I've tried to compile the pop3 extension with PHP 4.4.0, but that doesnt work:
Compiling pop3.c...
pop3.c:392: undefined identifier 'STREAM_XPORT_CLIENT'
pop3.c:397: illegal implicit conversion from 'int' to
pop3.c:397: 'struct _php_stream *'

Errors caused tool to abort.

I searched through the PHP sources but seems these defines are not present with PHP4.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-25 17:48 UTC] ilia at prohost dot org
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on

In case this was a website problem, the change will show
up on the website in short time.
Thank you for the report, and for helping us make PECL better.

Version 1.0.2 released with a fix.
 [2005-07-30 09:08 UTC] eflash at gmx dot net
thanks for the quick fix!
Works fine with PHP 4.3.11 and 4.4.0 now;
just compiled and tested on NetWare and Win32.
However on Win32 there's a warning about signed-unsigned:
.\ext\pop3\pop3.c(768) : warning C4018: '>' : conflict between signed and unsigned

I guess that's not so important.

PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC