php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56446 Problems with cached Scripts using SPL
Submitted: 2005-07-09 17:46 UTC Modified: 2005-07-20 16:28 UTC
From: akorthaus at web dot de Assigned:
Status: Closed Package: APC (PECL)
PHP Version: 5.1b3 OS: Linux 2.4.31 (gentoo)
Private report: No CVE-ID: None
 [2005-07-09 17:46 UTC] akorthaus at web dot de
Description:
------------
I ran into problems with "serverstats" (http://www.webmasterpro.de/~ddanier/serverstats/), which makes heavy use of new php5 features.

Once the scripts are cached, many segfaults are written to Apache error_log:

[Sat Jul  9 22:53:13 2005] [notice] child pid 13976 exit signal Segmentation fault (11)

sometimes when I test it (press F5 a lot of times...) I also get errors like:

Allowed memory size of 67108864 bytes exhausted (tried to allocate -136115724 bytes)

(I don't understand why, my memory_limit=64M. But there is no load, only the very small script)

Reproduce code:
---------------
<?php
class config implements ArrayAccess, IteratorAggregate
{
        public function offsetExists($offset){}
        public function offsetGet($offset){}
        public function getIterator(){}
        public function offsetSet($offset, $value){}
        public function offsetUnset($offset){}
}
$t=new config();
var_dump($t);
?>


Actual result:
--------------
signal Segmentation fault (11)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-20 16:28 UTC] akorthaus at web dot de
After upgrading from APC 3.0.3 to 3.0.4 and PHP 5.1b2 to 5.1b3 the problem seems to be solved. Up to now no segfaults anymore. 

Thanks a lot!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jan 26 15:03:33 2022 UTC