php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56432 php.ini syntax error when running configure
Submitted: 2005-06-28 13:30 UTC Modified: 2005-10-23 05:59 UTC
From: mjs15451 at hotmail dot com Assigned:
Status: Not a bug Package: Fileinfo (PECL)
PHP Version: 5.0.3 OS: Gentoo
Private report: No CVE-ID: None
 [2005-06-28 13:30 UTC] mjs15451 at hotmail dot com
Description:
------------
I'm running php 5.0.4 (no option for it in PHP version?).  Here's what I did:

1. tar zxvfm Fileinfo-0.3.tgz (inside ext src directory)
2. mv Fileinfo-0.3 fileinfo
3. sh ../../scripts/phpize
4. ./configure --with-php-config=/etc/php.ini

The configure stops and I get this error: 

checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
/etc/php.ini: line 1: [PHP]: command not found
/etc/php.ini: line 3: syntax error near unexpected token `;;'
/etc/php.ini: line 3: `;;;;;;;;;;;;;;;;;;;'
configure: error: Cannot find php-config. Please use --with-php-config=PATH

Expected result:
----------------
fileinfo should configure

Actual result:
--------------
Throws an error when attempting to configure when pointing to the php.ini file.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-28 13:33 UTC] mjs15451 at hotmail dot com
I would also like to compile this module statically but when I remove the old main php configure file and run ./buildconf --force in the php src directory, the --with-fileinfo flag isn't added to that configure file.
 [2005-08-02 17:31 UTC] mjs15451 at hotmail dot com
I figured out what the problem was.  I didn't know that for every new extension you add to php, you have to delete the previously compiled source and untar it again so it will detect the new extension.  It seems strange that the only time the php configure script will detect an extension is if it is newly untarred.
 [2005-10-23 05:59 UTC] mike@php.net
Sorry, but your problem does not imply a bug in PECL itself.  For a
list of more appropriate places to ask for help using PECL, please
visit http://pecl.php.net/support/ as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PECL.

--with-php-config should point to the php-config script not to php.ini
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 14:03:37 2021 UTC