php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56422 Return value of runkit_method_redefine()
Submitted: 2005-06-22 07:31 UTC Modified: 2007-01-31 03:30 UTC
From: emo at emo-cz dot net Assigned:
Status: Closed Package: runkit (PECL)
PHP Version: 5.0.3 OS: Gentoo Linux
Private report: No CVE-ID: None
 [2005-06-22 07:31 UTC] emo at emo-cz dot net
Description:
------------
runkit-0.3.0

Second redefine in example was finished OK, but seems that runkit_method_redefine() still returns false. But should be true as wrote in manual (Returns TRUE on success or FALSE on failure.)

Same problem is with runkit_method_add(), maybe with others too.

PHP Version:

PHP 5.0.4 (cli) (built: Jun 21 2005 22:17:48)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.4-dev, Copyright (c) 1998-2004 Zend Technologies
    with eAccelerator v0.9.3, Copyright (c) 2004-2004 eAccelerator, by eAccelerator


PHP Build Configuration:

Configure Command =>  './configure' '--prefix=/usr' '--host=i686-pc-linux-gnu' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--datadir=/usr/share' '--sysconfdir=/etc' '--localstatedir=/var/lib' '--disable-cgi' '--enable-cli' '--with-config-file-path=/etc/php/cli-php5' '--without-pear' '--disable-bcmath' '--without-bz2' '--disable-calendar' '--without-cpdflib' '--disable-ctype' '--with-curl' '--with-curlwrappers' '--disable-dbase' '--disable-dio' '--enable-exif' '--with-fam' '--without-fbsql' '--without-fdftk' '--disable-filepro' '--disable-ftp' '--with-gettext' '--without-gmp' '--without-hwapi' '--with-iconv' '--without-informix' '--without-ingres' '--without-interbase' '--without-iodbc' '--with-kerberos=/usr' '--enable-mbstring' '--with-mcrypt' '--with-mcve' '--enable-memory-limit' '--without-mhash' '--with-mime-magic=/usr/share/misc/file/magic.mime' '--with-ming' '--without-mnogosearch' '--without-msql' '--without-mssql' '--with-ncurses' '--without-oci8' '--without-oracle' '--with-openssl' '--with-openssl-dir=/usr' '--without-ovrimos' '--disable-pcntl' '--without-pfpro' '--with-pgsql' '--with-pspell' '--without-recode' '--enable-shmop' '--without-snmp' '--disable-soap' '--enable-sockets' '--without-sybase' '--without-sybase-ct' '--enable-sysvmsg' '--enable-sysvsem' '--enable-sysvshm' '--with-tidy' '--disable-wddx' '--with-xsl' '--with-xmlrpc' '--disable-yp' '--with-zlib' '--disable-debug' '--without-cdb' '--with-db4' '--without-dbm' '--without-flatfile' '--with-gdbm' '--with-inifile' '--without-qdbm' '--enable-dbx' '--with-jpeg-dir=/usr' '--with-freetype-dir=/usr' '--with-t1lib=/usr' '--enable-gd-jis-conf' '--enable-gd-native-ttf' '--with-png-dir=/usr''--with-tiff-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-gd' '--with-imap' '--with-imap-ssl' '--with-ldap' '--with-ldap-sasl' '--with-mysql=/usr/lib/mysql' '--with-mysql-sock=/var/run/mysqld/mysqld.sock' '--with-mm' '--without-msession' '--enable-sqlite-utf8' '--enable-dba' '--with-readline' '--without-libedit' '--enable-versioning'


System:

Linux emo 2.6.11-gentoo-r9 #1 Fri May 20 02:54:29 CEST 2005 i686 Pentium III (Coppermine) GenuineIntel GNU/Linux

Reproduce code:
---------------
http://hydra.emo-cz.net/tmp/runkit.phps

Expected result:
----------------
 one
 two
 
Warning: runkit_method_redefine(): first::on() not found in /home/emo/work/riviang/emo/recode.php on line 22
 Change error
 Change ok
 one
 Changed two


Actual result:
--------------
 one
 two
 
Warning: runkit_method_redefine(): first::on() not found in /home/emo/work/riviang/emo/recode.php on line 22
 Change error
 Change error
 one
 Changed two


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-23 10:27 UTC] mike@php.net
Please try the latest package version and report back if you're still experiencing this issue.
 [2006-02-27 07:22 UTC] mike@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2007-01-31 03:30 UTC] emo at emo-cz dot net
I can confirm that bug has been fixed.
Thank you
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun May 16 09:01:23 2021 UTC