PHP :: Bug #56407 :: make fails: [php_xmlreader.lo] Error 1
php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56407 make fails: [php_xmlreader.lo] Error 1
Submitted: 2005-06-02 17:08 UTC Modified: 2005-10-23 09:29 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: akorthaus at web dot de Assigned:
Status: No Feedback Package: xmlReader (PECL)
PHP Version: 5.0.3 OS: Linux 2.4.30 (Gentoo, x86)
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-06-02 17:08 UTC] akorthaus at web dot de
Description:
------------
If I try to install xmlreader, make fails:

/tmp/tmpdytc0q/xmlreader-1.0.1/php_xmlreader.c:31:32: ext/dom/xml_common.h: No such file or directory
make: *** [php_xmlreader.lo] Error 1
`make' failed

same with php 5.0.4 (other server, kernel 2.6, amd64)


Reproduce code:
---------------
I tried `pear install xmlreader`
I also tried manual install (phpize && ./configure --with-xmlreader && make)

Actual result:
--------------
lots of lines like that:

/home/akorthaus/src/xmlreader-1.0.1/php_xmlreader.c:1065: error: (near initialization for `xmlreader_functions[22]')
/home/akorthaus/src/xmlreader-1.0.1/php_xmlreader.c:1066: error: syntax error before '}' token
/home/akorthaus/src/xmlreader-1.0.1/php_xmlreader.c: In function `zm_startup_xmlreader':
/home/akorthaus/src/xmlreader-1.0.1/php_xmlreader.c:1075: error: `zend_object_handlers' undeclared (first use in this function)
/home/akorthaus/src/xmlreader-1.0.1/php_xmlreader.c:1075: warning: passing arg 2 of `memcpy' makes pointer from integer without a cast
/home/akorthaus/src/xmlreader-1.0.1/php_xmlreader.c:1076: error: request for member `read_property' in something not a structure or union
/home/akorthaus/src/xmlreader-1.0.1/php_xmlreader.c:1077: error: request for member `write_property' in something not a structure or union
/home/akorthaus/src/xmlreader-1.0.1/php_xmlreader.c:1078: error: request for member `get_property_ptr_ptr' in something not a structure or union
/home/akorthaus/src/xmlreader-1.0.1/php_xmlreader.c:1081: error: structure has no member named `create_object'


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-16 08:37 UTC] rrichards@php.net
Can you try it with PHP 5.1 as it looks like it may fix your issue?

Otherwise, for current workaround, copy the xml_common.h file from the dom ext source to /usr/include/php/ext/dom/ (or your equivalent dir).
 [2005-10-23 09:29 UTC] mike@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2011-09-26 02:50 UTC] damir21 at hotmail dot com
I have the same problem with 5.3.8
I tried with pecl install

but I got an error with phpize saying 

Cannot find config.m4. Make sure that you run 
'/usr/local/bin/phpize' in the top level source directory of 
the module

so I did it manually... got in pecl donwloads untarred and 
phpized the extension... and configure it... on make I get 
this error:



/bin/sh /tmp/pear/download/xmlreader-1.0.1/libtool --
mode=compile cc  -I. -I/tmp/pear/download/xmlreader-1.0.1 -
DPHP_ATOM_INC -I/tmp/pear/download/xmlreader-1.0.1/include -
I/tmp/pear/download/xmlreader-1.0.1/main -
I/tmp/pear/download/xmlreader-1.0.1 -I/usr/local/include/php 
-I/usr/local/include/php/main -I/usr/local/include/php/TSRM 
-I/usr/local/include/php/Zend -I/usr/local/include/php/ext -
I/usr/local/include/php/ext/date/lib -
I/usr/local/include/libxml2  -DHAVE_CONFIG_H  -g -O2   -c 
/tmp/pear/download/xmlreader-1.0.1/php_xmlreader.c -o 
php_xmlreader.lo
 cc -I. -I/tmp/pear/download/xmlreader-1.0.1 -DPHP_ATOM_INC 
-I/tmp/pear/download/xmlreader-1.0.1/include -
I/tmp/pear/download/xmlreader-1.0.1/main -
I/tmp/pear/download/xmlreader-1.0.1 -I/usr/local/include/php 
-I/usr/local/include/php/main -I/usr/local/include/php/TSRM 
-I/usr/local/include/php/Zend -I/usr/local/include/php/ext -
I/usr/local/include/php/ext/date/lib -
I/usr/local/include/libxml2 -DHAVE_CONFIG_H -g -O2 -c 
/tmp/pear/download/xmlreader-1.0.1/php_xmlreader.c  -fPIC -
DPIC -o .libs/php_xmlreader.o
/tmp/pear/download/xmlreader-1.0.1/php_xmlreader.c: In 
function ?xmlreader_read_property?:
/tmp/pear/download/xmlreader-1.0.1/php_xmlreader.c:137: 
error: ?zval? has no member named ?refcount?
/tmp/pear/download/xmlreader-1.0.1/php_xmlreader.c: In 
function ?xmlreader_objects_new?:
/tmp/pear/download/xmlreader-1.0.1/php_xmlreader.c:349: 
error: ?zend_object? has no member named ?in_get?
/tmp/pear/download/xmlreader-1.0.1/php_xmlreader.c:350: 
error: ?zend_object? has no member named ?in_set?
make: *** [php_xmlreader.lo] Error 1


please advise ASAP
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Tue Aug 21 02:01:28 2018 UTC