php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5637 sybase_fetch_array() returns multi-dimensional array
Submitted: 2000-07-17 07:56 UTC Modified: 2000-09-05 04:52 UTC
From: joschug at aol dot com Assigned:
Status: Closed Package: Sybase (dblib) related
PHP Version: 4.0.1pl2 OS: SunOS 5.6 (sparc)
Private report: No CVE-ID: None
 [2000-07-17 07:56 UTC] joschug at aol dot com
some queries (not all) return an array as result that contains other arrays and not plain key/value entries. this does not happen always and isn't really reproducible.

if i put the same script on a linux box (with php4.0.1pl2) and let it run against the same database, everything works fine.


configure:

'./configure' '--with-mysql' '--with-apxs=/usr/local/apache/bin/apxs' '--with-sysvshm' '--with-sybase=/usr/syb119' '--disable-debug' '--with-config-file-path=/usr/local/apache/conf'


php.ini: default

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-09-04 20:39 UTC] sniper@php.net
Are those sybase libs the same version in both of your systems?
And is this still happening when using php4.0.2 ?

--Jani
 [2000-09-05 03:34 UTC] joschug at aol dot com
The machine with the problems is running SunOS 5.6 with ASE 11.9 installed, the Linux box has only the libraries installed that are needed to access Sybase.

I don't know the exact version of the libraries (how can I get that?).

In the meanwhile we've switched from dblib to ctlib and the problems disappereared.

I didn't try PHP 4.0.2 yet.

~jo
 [2000-09-05 04:52 UTC] sniper@php.net
As dblib isn't supported by sybase anymore
and while you have moved to ctlib and it solved
your problems, I'll close this bug report.

--Jani
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Oct 15 20:03:45 2021 UTC