php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56368 error: The DSP perl.dsp does not exist.
Submitted: 2005-04-05 20:50 UTC Modified: 2005-08-03 11:12 UTC
From: jond10 at gmail dot com Assigned: mike (profile)
Status: Closed Package: perl (PECL)
PHP Version: 5.0.3 OS: winxp
Private report: No CVE-ID: None
 [2005-04-05 20:50 UTC] jond10 at gmail dot com
Description:
------------
Unable to install perl extention.

C:\>pear install perl
downloading perl-0.6.tgz ...
Starting to download perl-0.6.tgz (21,397 bytes)
........done: 21,397 bytes
5 source files, building
The DSP perl.dsp does not exist.

C:\>pear -V
PEAR Version: 1.3.5
PHP Version: 5.0.4
Zend Engine Version: 2.0.4-dev
Running on: Windows NT CVNDEFORIS06 5.1 build 2600

C:\>php -v
PHP 5.0.4 (cli) (built: Mar 31 2005 02:45:48)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.4-dev, Copyright (c) 1998-2004 Zend Technologies

C:\>cmd
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

Reproduce code:
---------------
C:\>pear install perl
downloading perl-0.6.tgz ...
Starting to download perl-0.6.tgz (21,397 bytes)
........done: 21,397 bytes
5 source files, building
The DSP perl.dsp does not exist.


Expected result:
----------------
package installed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-19 13:02 UTC] smelban at smwebdesigns dot com
I have had this same issue for months now with no help.  Today I'm thinking it is the fact that my computer XP Pro doesn't know how to handle tgz files. I think this because it downloads the file fine but can't find the files inside of it.  Anyone else have a solution for this ?
 [2005-08-03 11:12 UTC] mike@php.net
At this point it is not possible to install pecl extensions on widnows through the PEAR installer.

Please have a look at http://snaps.php.net for Win32 PECL DLLs.
 [2012-04-19 22:55 UTC] brent dot newland at casipc dot com
This bug is the root cause of the problem: http://pear.php.net/bugs/bug.php?id=17016
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Nov 23 22:01:26 2020 UTC